Servers by jDrones

ESC Calibration in APM:Rover 3.1.2 asking for AC3.3+

Hi All,

I am trying to calibrate ESC in mission planner’s/mandatory hardware and this message pops up “Set param error. Please ensure your version is AC3.3+”. My question is, what has AC3.3 has to do with the Rover? Isn’t AC for ArduCopter? Anyways, is there a way to go around this in the parameter and make it believe that everything is ok? Or, is there a way to test the motors without going through the ESC calibration?

I am using pixhawk

Thank you

Tee

That ESC calibration page is for Copters only I believe as its titled “ESC Calibration (AC3.3+)”. I’ve never tried it on a Rover. Do this AFTER you have calibrated your Radio Transmitter.

To calibrate on a Rover (which I notice I haven’t documented on the wiki - I need to fix that) set ARMING_REQUIRE to 0 and BRD_SAFETYENABLE to 0.

WARNING - when you power your rover it will be ARMED and ready to roll!!!

Now disconnect all power, put your transmitter full throttle (make sure your rover wheels aren’t touching the ground in case this goes wrong you don’t want the rover to take off) and then plug the power into the ESC. You should hear a special musical tone from the ESC/Motor, pull your throttle stick down to 0 and you should hear another special tone and that’s it. Remember to set ARMING_REQUIRE and BRD_SAFETYENABLE back to 1.

Thanks, Grant.

1 Like

Hi Grant, thank you for the reply and thank you for all your work and dedication.

Ok, I was able to arm by motor using GCS but when I wanted to disarm it using the same way it gives me the MAV error. But even though it was armed, I couldn’t test my motors because in the motor test no motor was highlighted and I don’t why they are not highlighted.

The following are something you need to see because I think it needs to be fixed.

  1. I couldn’t fine ARMING_REQUIRED in mission planner parameter but I could find it in QGC’s parameter list

  2. I couldn’t find the “save parameter” or “load parameter” in the planner

  3. I couldn’t reset my parameters to default in the planner

I hope this are simple things to fix and I will highlight other issues if I find so

Update: I was able to find all the things I highlighted so again thank you so much for your help.

Thank you

Tee

I tested ARMING and DISARMING via MissionPlanner 1.3.48 and the latest Beta of ArduPilot Rover its working fine for me. What version of ArduPilot are you running?

You might need the advanced view in MissionPlanner to see all the parameters. On the Config/Tuning tab under Planner make sure you have Layout “Advanced” selected. You might need to restart after this.

Thanks, Grant.

Hi Grant,

Thank you for your help, i was able to do everything as you said and I am almost at the end of my project. Now I am stack in one of the parameters configuration. I have almost done everything and I don’t know if I am missing something or doing it wrong; I am not able to make both the motors work. Here below is what I have done so far and what I am getting as a result.

Software and Firmware

Mission Planner: The latest stable version [3.1.48] does not recognize the gamepads so I am using the latest bet because it does recognize the gamepads

Firmware: ArduRover 3.1.2

My RCMAP is as follows

RCMAP_ROLL = 1
RCMAP_PITCH = 2
RCMAP_THROTTLE = 3
RCMAP_YAW = 4

I am using RC1 and RC3 for steer and throttle consequently

My skid steer parameter is SKID_STEER_OUT = 0 and SKID_STEER_IN = 1, on the safety side I didn’t select anything from the ARMING_CHECK and BRD_SAFETY is disabled. I can arm and disarm from the GCS and I disable ARMING_REQUIRED only when i want to calibrate the ESCs.

I am using XBox and Futaba Interlink RealFlight RC Simulator gamepads alternatively. These two gamepads are behaving differently. The XBox would give higher PWM ranges on both channels but the outcome is random and unpredictable. Every time I calibrate the ESC for the XBox gamepad, the thrusters behave differently and it is hard to understand what is going on. On the Futaba side, the problem I am seeing is that it has very low PWM range specially in throttle side and at the end of the configuration only one thruster works, this means only Pin-1 works. If i switch the cables on the Main Out, the other thruster works so the problem is somehow with Pin-3 which is not doing what it should do. I have tried to alter the ranges for both RC1 and RC3 using ranges 1100-1500-1900 for RC1 and 1100-1100-1900 for RC3 but it didn’t work.

I am attaching a log files in .bin and .log and the parameter and if you need more data I can send them to you.

Thank you

Tee
00000001.BIN (41.8 KB)
USV.param (8.7 KB)
00000001.log (42.5 KB)

Do you have a skid steering rover? Just motors on each side of the vehicle - no steering servo?

Thanks, Grant.

Hi Grant,

No steering servo, just motors connected to ESCs.

Thank you

Tee

SKID_STEERING_IN set to 1 means your going to do all the skid mixing in the transmitter. Almost all users DON’T want this setting. I think you should set SKID_STEERING_IN to be 0 and set SKID_STEERING_OUT to be 1 and try again.

If your not getting any output on either motor make sure you have successfully armed the rover.

Thanks, Grant.

I corrected the SKID_STEERING, I am using only the XBox gamepad and I am using the right side for Throttle. The center of the key is my MIN and TRIM and if I push it up it is my MAX. The left side is for Roll. Pushing left is MIN center is TRIM and right is MAX. Roll is working fine for the three positions. The throttle on the other side is doing something different; if I push up the left motor works if I push down the right motor works, it is behaving the same as the Roll. What I want to do instead is, when I push up I want both left and right motors to spin. I want both of the motors to receive the same values when I push up on the throttle.

Thank you for everything.

Tee

Can you attach a new log file for when the issue occurs please and I’ll have a look.

Thanks, Grant.

I was able to solve the problem by increasing the dead zone value for both RC1_DZ and RC3_DZ from 30 to 60 and as of yesterday it seemed to work without a problem. The reason I did that was because one of the keys on the gamepad is wobbly in the trim area so I just wanted to eliminate the sudden motor movement from this wobbliness. This made both motors to work but I doubt if they are receiving the same PWM values and I can’t explain why it worked either. I will check that in the status once I get home and I will send you a new log file with it.

Thank you

Tee

Here is the log file

Thanks,

Tee

1 1-1-2000 7-10-48 AM.bin (29.6 KB)

That log file is effectively empty. I need one where you were driving the vehicle and the issue occurred.

Note you have your throttle reversed. Generally with electric motors if they are reversed people swap around the wires going from the ESC to the motor. Not sure what combination of motor/ESC you have so it might not be possible for you - just thought I’d mention it.

And its always a good idea to have arming checks on - your ARMING_CHECK is set to 0 and it really should be 1. If your checks are failing it means something is wrong and that should be fixed - not worked around.

Thanks, Grant.

I also have the known problem with the message (Please ensure your version is AC3.3+)
I have the arducopter 2.8
Which version of the Miss Planner and which for firmware ?
It is possible to calibrate the escs of arducopter 2.8 ?

Servers by jDrones