ESC are ok in calibration, but strange in ARMED

Hello. When I’m calibrating ESCs all at once they are in sync. But in ARMED mode it looks like there is no level, motor 2 not rotating at low throttle and 6 is rotating slow. But accelerometer is calibrated, when I’m checking it in APMPlanner.

I think you have ti Make a new acc calibartion. Maybe the cooter isn’t 100*/* horizontal calibr.

Similar situation for me!
Pixhawk 3.2 with 4 afro ESCs with 6S battery.

I calibrated the ESC and the motors spin slowly and beautifully.
When I cycle power and try to arm it wont spin slowly even if MOT_SPIN_ARMED is set to 70 or more.
When given a bit of throttle, one motor spins rapidly while the others are slow-ish.
Only sometimes it gets to spin the motors when arming.
There is an aggressive jump between armed min speed and a bit faster.

I can accept that the varying speeds are due to inclination in my table, but the fact that it is not spinning the motors when arming is not acceptable.

Motor test wont spin the motors until at least 15% or 20% is set.

@plus. Are all esc calibratet with the same options?

That shouldn’t happen. Can you post a log of this. It would be interesting to see the motor outs that are being sent to each motor. This will tell us what should be happening.

At startup the motors should be at about 1100. This should spin the motors. Anything less not so much.

Mid throttle should be at 1500 and max close to 2000.

Logging needs to be set to Nearly All so we can see the RCOUT numbers and the RCIN from the radio.


On top of Mikes post, also check the AHRS pitch and roll trim parameters don’t have some excessive incorrect value.

Also check you don’t have any trim on roll/pitch on your radio

Post a log as Mike suggests.

Thanks for the feedback, check out this tlog.
you will see:

  1. Arm, RC outputs 1-4 go from 1118 to 1188. Motors didnt spin at all.
  2. I slowly trim the THR stick up until motors start spinning aggressively, two of them jump directly to around 1450.

I tried using the 3DR quad X4 parameters and it does the same.

I wanted to see if the ESCs are wrongly calibrated so I tested them at 10% and they spin slowly, peacefully.
By the way I did the normal all-together calibration of ESCs.

Sharing my paramaters, video, and the log file of the video.
In all-at-once ESC calibration mode motors are spinning in sync.

No need to send the parameters as they are part of the log file.

You need to set logging higher as 894 won’t cut it. For the test we need it at Nearly-All: … og_bitmask

This will give us Throttle outs on each motor.

When it’s working you need to set it back down for APM as this puts a load on the controller.


As I understood, I need to set this bitmask:
1854 Default+Motors

Have you tried swapping temporarily two motors and/or two ESCs ? that would rule out a mechanical problem. I broke a propeller in mid air due to a faulty bearing in a motor, barely unnoticeable.

Any comments on my previous post?

I would like to see other items as well. Like Pitch, Roll and if it thinks it’s leaning one way or another.

Someone else with a Hex is reporting flip overs as well.

He was checking the order of his motors…


Here is my motors log

Motor logs seem to match you descritption. Its trying to roll left.

Can you also log RCin?

Your att log shows that des roll is 12 degrees bank left after you throttle up. If you aren’t trying to roll it should be zero.

Hey it was me reporting a hexa fliping on takeoff;) I do notice the same “kick” when moving the throttle slightly. Also I have noticed something odd while testing motors using the motor test under initial setup. Sometimes if I hit a button for e.g. motor D, motor B will twitch. Sometimes after testing the motors (and I´m more than sure the order and spin direction is correct), the ESCs start to beep slowly until I reboot the whole system.
Sorry, I don´t want to highjack this thread :wink:

When I’m trying to load 45054 mode log, APMPlanner is returning error message.

Ok. Here is my 131070 mode log.

Why DesRoll goes from 0 to - 10 at start, when I’m putting throttle up?

Not seeing that in the log. Only see that motor 1 is running higher than the reset.

Roll, Pitch are all flat like they should be.

You could try an experiment. Remove the props and arm the copter and raise the throttle a little. Then pick the copter up and lean it left then right then forward then backwards. You should see the motors speed up and slow down based on which way you lean it. Then upload the logs.


Here the blue one is DesRoll, which goes to -10.5 right after first throttling.
It tried this experiment, but without logging. Will try again later.