Servers by jDrones

Error when use 2 differents Serial Lidar

Hi team,

My project is to Pixhawk 1 - Arducopter 4.0.1 with 2 radars type UART, but each serial port are different type ! first radar is 1 sector to altimeter and secund is 3 sector to proximity.

The each radar work very well when is alone, but together have a conflit.

First Radar (have a 1 sector) to altimeter:
Serial2_type = 9 (Rangefinder)
RNG_Orient= 25 (down)
RNG_type = 11 (uLanding)

Secund Radar (have 3 sectors) to proximity:
Serial4_type = 11 (Lidar360)
RNG_Orient= 0 (Forward)
RNG_type = 11 (uLanding)
apx_type = 3 (TeraRangerTower)

When I try this, the RangeFinder1 show the correct value, when proximity is not detect, alternating this.

Any ideia how to fixe this ?

obs.: I did modify code to fixe uart port and copy other instance uLanding to LeddarOne (copy of uLanding), but I didn’t work well !!!

thank you

2 Likes

We really can’t help unless you’re using unmodified code: you’re having uart trouble and have modified the uart code.
Perhaps if you make a pull request with your changes someone can have a look at your code.

1 Like

thank you, I will do pull request ! but, I need review my project urgently, I tried fixed in code, but didn’t worked, because the problem is in Rangefilder identified and not in parse code of radar !!!

Servers by jDrones