"Error Uploading Firmware"

So I tried to update both of my Pixhawks’ firmware to ArduPlane V3.0.1 (BTW thanks for the update, excited to use the new features!) today via Mission Planner 1.2.99. After Mission Planner downloaded the firmware, I unplugged and re-plugged the pixhawk as instructed. In the status bar I see “identify, updating, erase, then program…” I get to anywhere from 10-80% complete, then I get the dreaded “Error Uploading Firmware” and an “ERROR: the operation has timed” out message near the status bar. Now I can no longer connect via mavlink and I no longer get a start up tone from pixhawk (or any tone for that matter) and no main LED indications.

I’ve tried: to upload copter and rover and older versions of arduplane, using APM instead of Mission, second Pixhawk. All with the same results, and as of now I have a couple of fancy paper weights.

Has anyone ran into the same problem?

Ok, so I uninstalled Mission Planner and all its associated files, and uninstalled the pixhawk drivers from my computer, re-installed MP and connected pixhak again. Same problem, “ERROR: the operation has timed out”. Will try to update via SD card tomorrow.

Updated both Pixhawks via SD, finally got mavlink connection and 3.0.1 update. Don’t know why MP wouldn’t talk to pixhawk.

That is very strange, as there is actually no mechanism to update a Pixhawk via SD card (the SD card only holds logs, not firmware).
If the buzzer made any sounds, can you tell us what sound it was from these:
plane.ardupilot.com/wiki/common- … PX4_Sounds
Cheers, Tridge