Error receiving log list

Hello guys, when i trie to download my data flash logs from my APM 2.6 i get an error : Error receiving log list

Does anyone know why ?

Really… 138 views…

No one encountered this before ?

Hi there. Yes I got this too. Can’t figure it out. Have you found the answer?

What type of multi rotor?

Not, Plane

[quote=“davely”]Hi there. Yes I got this too. Can’t figure it out. Have you found the answer?

What type of multi rotor?[/quote]

Oh i forgot do you have a clone or original ?

I also get the same error… I searched and searched for a solution but found nothing. I have still found nothing.
Is your LOG_BITMASK set to the pixhawk defaults? If it is and you also get this error then we are in the same boat sadly. And seemingly without a solution as yet.

how are you trying to download logs off the APM? You should connect via USB, then goto the ‘Dataflash Logs’ section under the “Flight Data” screen, then click download dataflash via mavlink. attached a picture

Yup. Following that method but still nothing comes of it.

I’ve seen that error a lot when trying to download using wireless but never when using USB.

I should add a clarification that I am using a Pixhawk by the way… still the same error message though.

If I plug the SD card into a reader I can pull the xxx.bin logs off manually.

I gave up on APM.

Sometimes it works, then the other time it doesn’t.
Not reliable enough for me.

What have you moved to?

Interesting. I have flown dozens of flights and downloaded dozens of log files and never had that error until just recently. No matter how I connect, I keep getting the same error “error receiving log list”. As a temporary work-around, I pull out the micro SD and copy the .bin files off then use Mission Planner to convert them to .log, .kml, .gpx, etc. files. I would also like to know how to fix that problem.

@Mitchell - when you say gave up I assume you mean downloading the logs?

I would try a couple of different things.
Firstly, on a pixhawk I would pull the SDCard, format it on a computer and then put it back in. Sometimes they can be a little corrupt and the pixhawk doesn’t like it.
For MP users I would uninstall MP and then install the latest version. This ensures you have the most up to date USB drivers which can help when trying to download log files.

Let us know how you go.

Thanks, Grant.