Engines run without arming

Hi all,
going from 4.2 to 4.3 when the small 2 "drone power supply is activated, 3 out of two motors start to rotate (little and jerky), without giving the arming command. by activating the arm switch the motors rotate normally and the quad flies regularly. Parameters have changed between 4.2 and 4.3?


Here are my current parameters:

my esc:

If you haven’t turn on BL Heli in your parameter settings, do so. Instructions are in the WIKI. Your ESC supports it so why not make use of it.

Thank you. However, it seems that using Dshot 600 the problem is solved. Would I benefit from switching to BLheli?

You don’t have to calibrate the ESC if you are using BLHeli. And the RPM is more consistent compared to PWM. I think when you are on PWM, you did not calibrate your ESC hence some motors thinks that they are commanded to start spinning at min throttle. You should have solve your issue by calibrating your ESC but why bother if you have a BLHeli ESC. Utilize the features of your ESC. Don’t forget to upgrade the firmware of your ESC to the latest version. Here’s what I am using. Version 32.9.

I have never used PWM. If you see my setting it is DShot 150 (digital without calibration) and it has always worked well. From 4.3 I get that weird engine behavior. Now I put option 6 = Dshot 600 and the problem seems to be solved.

I was told that DShot lower than 600 is problematic. Maybe this is the case for you.