Servers by jDrones

Enable geofence without autotakeoff

(Tuna Lobster) #1

I am trying to find a way to enable a geofence in SITL without an autotakeoff. Since there is no way to have RC channels pass through I am struggling to find a way to get the fence to turn on. Is there a button in Mavproxy or Mission Planner that I am waiting on?

(Tuna Lobster) #2

I solved this by changing rc channel on the mavproxy console and changing the PWM of the FENCE_CHANNEL parameter.

(peterbarker) #3

Try:

fence enable

at the command-line.

(Tuna Lobster) #4

Thanks! Mavproxy fence command list is here for reference http://ardupilot.github.io/MAVProxy/html/uav_configuration/geofence.html