Elevons fine in manual mode all other modes a mess

After turning the Mixing_Gain to 1, I can see the problem clearly now. One elevon was doing most of the correction with the other barely responding depending on what it was trying to correct pitch or roll movements on the airframe (X-79 Buffalo).

When in manual mode elevons deflect as expected, pull back on stick, both elevons rise, push forward, they both go down. Left stick causes left elevon to rise and right on to lower etc…

When I go into FBWA or Stabalize mode, APM treats rolling of the airframe as pitch corrections and pitching of the airframe as roll corrections on the elevons.

I’ve experimented with ELEVON_OUTPUT all the combinations and that either reverses or causes only one elevon to actuate and tried all the options on the Elevon Config box.

I’m relatively new at this and the not up to collecting of logs yet so I could not attach. From what I’ve observed the Elevon Config from the initial setup created the proper mixing, but somehow the APM is 90 degrees off on its correction output?? Arrow is pointing forward, plugs are on top. Accelerometers are all calibrated OK that I know of based off HUD in Flight Data. I may be crazy, but I don’t remember seeing this until after I upgraded from 3.2.1 to whatever the latest push was.

Hopefully someone can decipher this and give me the proper correction, no pun intended.

Thank you Grant

When I flew it I was running AR8000 with satellite and delta wing in the DX9 so the transmitter was mixing; then I transferred receiver configuration and just the satellite over to PIXHAWK (sorry, not APM) with a few additional mixes for flight mode on another channel and a mod to the output limit for throttle.

Like you suggested I started in manual, bench tested and thought I was ready to maiden. Then I found this problem in STABALIZE and FBWA. At this point I’m second guessing everything… I’ve switched mixing from the receiver to PIXHAWK and tried starting from scratch with config in Mission Planner. We’ll see how that goes.

I’m hoping that I will find something here or anyplace that might shed light on what I’m doing wrong (agree 100% it can be tricky) or if there is a true short coming for using a delta airframe. I’ve seen youtube’s of people who demonstrate that it can be done just scratching my head…

Again, thanks for the advice and suggestions

quote=“gosmondson”]here are some tips that I ran while setting up a couple elevon planes (using both APM and Pixhawk)…

First, get them working using just the RC Transmitter and Plane, no autopilot neded. (I usually fly and trim the plane here)

Next hook them up using autopilot, and make sure to RE Calibrate the transmitter in Mission Planner (Throws change with Elevon mixing enabled, unless you use 100%)…

Then set the ELEVON_OUTPUT option (this has 4 different options, UPUP, UPDOWN, DOWNUP, DOWNDOWN). Go through each one of these and confirm if the autopilot controls work properly in MANUAL MODE…

Next switch to STAB or FBW and check to make sure they STILL work properly, and if not go back into the RC Calibration page, and reverse a channel (The channels you would want to toggle are the Elevator, and Aileron)…

Its a semi pain, but this has worked through quite a few wings, but elevons are always a bit of testing and tweaking to make them work right…[/quote]


Thank you for the time and advice.

Started from scratch, chose “Elevon B” this time in Spektrum for wing type, followed your instructions, no need to reverse anything in MANUAL MODE (ELEVON_OUTPUT=0). Held my breath, flipped to STABALIZE, moved the sticks, good so far… :wink: made some airframe axis changes and SHAZAMMM proper correction was applied by PIXHAWK! Happy dance :smiley:

You da man!

Turn everything off, unplug go out for dinner have a celebratory beer, all’s well… until I plug it back in power up.

Elevons react to stick correctly in MANUAL and STABALIZE, but now STABALIZE corrections are backwards again.


One last observation, when in MANUAL mode watching the failsafe screen in Mission Planner, Radio 1 and 2 inputs are mirrored by the Servo/Motor OUT even when I flip the flight mode into STABALIZE.

But as I said before, when I go into STABALIZE mode, Pixhawk treats rolling of the airframe as pitch corrections and pitching of the airframe as roll corrections on the elevons. Roll the airframe right and both elevons go up (nose up position), pitch the airframe nose down and right elevon goes up, left goes down position (right turn).

What would cause only the corrections to be off and not the outputs from the receiver? What would cause this to stop working when it was working before the power down? I’ve searched all over the place and cannot find what or how to reverse corrections but not affect input. I’ve seen earlier in the forum when Trigg made some changes for no output (0 vs 1 or -1) but nothing like this yet.


Could you post some logs please. Both tlog and data flash .bin and I’ll have a look.
Thanks, Grant.

I hope I did this right, it’s my first time doing this

Thank you

Ignore the last one this is it. I started in manual mode moved stick. One that was complete I put in STABALIZE mode, moved stick and control surfaces deflected as expected. After that I pitched and rolled the airframe twice in each direction and pixhawk applied wrong correction. Disarmed and then disconnected.

I noticed you had THR_PASS_STAB set to 1. Did you really mean this? Definition is here:
plane.ardupilot.com/wiki/ardupla … _pass_stab

The rest of your settings seem ok. To clarify settings the RC#_REV settings are for fixing the direction of servo travel in any mode where the autopilot is performing some sort of control. So, if nose goes up due to wind gust for instance and the autopilot wants to put it down it tries to lower the elevator. Depending on which way the servo is installed for the elevator this may actually raise or lower the elevator so you set RC#_REV correctly so it moves in the right direction.
You THEN need to change your transmitter when your in manual mode so it matches and moves the surfaces in the direction that matches the controls. Make sense?

Thanks, Grant.

Not related to this topic, but I use throttle pass stab on all of my planes to get manual throttle control in FBWA. It still uses airspeed-based throttle control for Cruise and Auto (which you can bump up with nudge enabled).

Yes, I prefer to just pass it through since I was new to all this. I just wanted to use it as a gyro stabilizer not complicate the learning process/curve.

I finally found something that helped after a hiatus.

In the Spektrum transmitter I changed it back to Wing=Normal (ailerons and no mixing).

Then I followed this and used the new style mixing instructions:
plane.ardupilot.com/wiki/ardupla … evon-mode/

Initial setup that worked was:

The only other param I had to change:

I’ve noticed that the responses are a lot crisper when flying in stab mode, and there have been no occasional “glitches” since following those instructions and taking mixing out of the transmitter.

Now I’m working on gains, airspeed etc.

Thank you Grant

Glad its working for you. We generally advise to make the transmitter as simple as possible and do the config in the autopilot as it has a lot more information at its disposal for decision making - hope that makes sense.

Thanks, Grant