Elevon deflection during start up

I am using Pixhawk Black Cube. Whenever I am trying to boot up my system, sometimes the elevon starts moving before pressing the safety switch. This happens around 40% of the time of booting up and it’s random. The deflection goes back to trim whenever I press the safety switch.
The elevons are getting power before the safety switch is pressed. I just wanted to know how can I prevent it from happening. I am using Here 2 GPS as my safety switch.

Pixhawk does that upon startup, however if it bring the control surfaces not center then it’s problem.
Check few things: by default ardupilot not running in stablize, fbwa or b, rtl mode. It should startup in manual mode ones powered on.

Servo get power without safety switch on:
Yes, that can be changed under settings. By default servo and other equipment will response to your TX regardless safety switch is on or not. Only armed will not work unless safety’s switch is on+ other armed settings.

If all above does not solve the issue:
Reset the paprametera and re-calibrate everything including radio calibration + gyro etc.
OR I would suggest just reload the ardupilot and start from scratch.

I have tried multiple things, changing the parameters, checking the output signal of each pin in pixhawk. Only thing that worked is keeping the servo channels separated. Usually, I use 1/2/3 for the elevons and throttle, now I am using 1,4, and 7. It seems to work for me.