EKF IMU1 mag anomaly

I am working on drone which is of 2 kgs. Every thing has been done properly. But when ever we take flight, we face
EKF IMU0 mag anomaly
EKF IMU1 mag anomaly
EKF yaw inconsistant
compass variance


and the drone keeps yawing unstably. I have tried calibrating multiple time accelerometer, compass. and it shows good when calibration is done. Also all the electronics has been kept far from the pixhawk and compass

Can you help in letting me know what could be the issue.

First off, upgrade to ArduCopter 4.0.7 It contains critical fixes

1 Like

Thanks for your reply. I did the same but still the same problem is shown. Any reason why this problem occurs. I tried turning off external compass by unchecking use compass. I also switch to only one IMU in EKF thinking that maybe IMU0 and IMU1 values mismatch is causing the error. But no improvement at all.

Can it be due to magnetic interference?

Post a link to the .bin log file (not the Tlog).

Please find the logs. Link


Post a link to one (1) log where the issue is present. You won’t find as much help if someone has to go thru directories of logs looking for a problem.