Servers by jDrones

DSHOT protocol in ArduPlane 3.9.8

(Maciej Szreter) #1

I can’t find any parameter for configuring DSHOT mode in ArduPlane 3.9.8. None of these described in the ArduPlane docs are present among my parameters.

[MOT_PWM_TYPE], [SERVO_BLH_OTYPE], or [Q_M_PWM_TYPE]

My plane is not a tailsitter, just a “normal” twin-motor airplane. Do I need to enable the tailsitter and then somehow (how?) disable most of it functionalities, but have access to the Q_M_PWM_TYPE parameter?

I use the DSHOT support in my copter, works really great, now I would want to move to the planes with this.

(Maciej Szreter) #2

I’ve found the problem. I have the NuttX version. Now I’ll install the ChibiOS-based AP and hope that the problem will be solved.

EDIT: the SERVO_BLH_ params have appeared, but I still can’t get the motors working. I can’t set the SERVO_BLH_TEST param to anything other than 0, it is reset to 0 after a second.

My settings:

SERVO_BLH_OTYPE: 4
SERVO9_FUNCTION: 73
SERVO10_FUNCTION: 74

And I connect the ESCs to AUX1 and AUX2 outputs. The FC is Pixhawk 2.4.8. What’s wrong here?

(Arthur Simonyants) #3

You might also need to set the SERVO_BLH_MASK parameter’s bits 9 and 10, which would yield (256 + 512) = 768.