Dshot ESC's with Pixhawk 2.4.8

Hi guys - Having quite a bit of trouble using Dshot ESC’s with Mission Planner with a Pixhawk 2.4.8 board, and looking for someone who may have encountered this issue before/ has a fix.

ESC Link: https://www.racedayquads.com/products/emax-bullet-35a-pro-edition-3-6s-esc?variant=757717336075&currency=USD&gclid=Cj0KCQiAtOjyBRC0ARIsAIpJyGOoFBXW_Y0a2wY6hTXXs7D4bvp03P2bDF_Y3v4W3I1kiCk5eXX0Uq8aAtdDEALw_wcB

This is for a new quad build I just put together - I’ve gone ahead and set the Servo9-12 outputs to act as motors 1-4, and set the Mot_PWM value to 4 for Dshot 150 (Have also tried Dshot 600). Basically, If I refresh the Pixhawk board to default settings (i.e. flash plane software and reflash with quad 4.0.3), and then set the servo/ Mod PWM values as stated above, for the very first initialization I can get the motors to behave as expected when arming the quad. However, after I unplug and plug back in, Nothing I do from that point on seems to actually engage the motors after successfully arming the quad, there is no throttle response.

Any help on this issue would be greatly appreciated!


You should have went with BLHeli32 ESC’s but post your parameter file anyway maybe there is something to see. Also, what does the messages screen show for RCout as in the attached example?

Thanks for the reply - Yeah I picked up on the Bl Heli 32 ESC differences a little too late in the game.
Param file.param (17.6 KB)

I’ve attached the param file and an image of the RCOut as well - Looks to be the same as you, PWM 1-8 DShot150 9-12.

Let me know if there’s any more info that may be helpful, thanks for looking into it!

Is this an OctoQuad or a 4 motor Quad? If it’s the later your Frame_Class is wrong. And you can’t run an OctoQuad on Dshot with a PIxhawk anyway, not enough FMU outputs.

Also, before attempting to fly this craft follow the basic tuning guidelines here:

Good catch… Yes it’s a quad, I must have forgotten to select the frame class during the last boot. I think I actually just figured out the issue… I had disabled all of the requirements to arm the aircraft, however for whatever reason it still disables the ESC’s without the mechanical arm switch. Using that, things operate as normally.

I’ll be sure to tune the quad as well, thanks for the guide!

Thanks for all your help!

After correcting the frame class I would clean up the SERVOx_PROTOCOL parameters. they are a bit of a mess :grinning:

The blasted safety switch. I never saw the reason why one would be used on a Multirotor. The 1st craft I built quite a few years ago now required reaching thru the props to push the button. That was the end of the safety switch for me…

Will do!

Yeah I’m certainly not a fan of the safety switch… This is my first go at a larger build, but having built quite a few smaller racing drones with CF/BF, The switch just seems to add safety risk more than anything else…

It’s easy to disable!

Also make sure you disable servo 1-4 if you are remapping them to 9-12

Params 3.1.20.param (17.6 KB) Good tip… Thanks guys!

Another question I’m hoping you guys may be able to help with… I’ve got the quad to the point where it should be able to fly, but when trying to take off, I’m getting a pretty aggressive oscillation, I believe it’s oscillating in the roll plane and possibly yaw too (It’s completely uncontrollable at this point, so not enough time to tell)…

Any help would be greatly appreciated. My experiences in the past on the small quads have been much easier to manage, as they’re usually flyable, just need a little PID tuning to square away, but this is uncontrollable from the start.

Also… It’s a Tarot XS690 build with 15 inch props


Params 3.1.20.param (17.6 KB)

The obvious 1st, did you perform the Motor Test in Mission Planner to check correct motor order and direction?

I did - All motors and directions are correct. Also another little issue which may be related if you have any thoughts on this… When I arm, one propeller will be idling and not really spinning up with the rest of them. I can ‘fix’ this by just nudging that prop a little by hand, then it responds as it should. There isn’t any kind of interference happening or added resistance to the motor compared to the others, so I think it’s probably signal related.

Where did you find the information about connecting the ESCs? I can’t find anything in the documentation on that.

What exactly do I have to do in Mission Planner to configure D-Shot escs?

Set MOT_PWM_TYPE to the protocol you want.