Drone tilt during take off

Hello everybody,

I’ve build a new drone using Hobbywing X8 rotors. Now when I want to take off, the drone tilts forward and wants to hit the ground.
I’ve tested the motor order, this seems correct. When I tilt the drone forward or sideways I see in missionplanner the correct direction of the tilt. So I would say this isn’t the problem. What I see in the log file, RCout3 is a lot lower then the other channels, but I can’t explain why.
The settings for the PWM range for all the motors are the same.
I’ve included the log file in the link below. This is not during a flight, since I can’t get it off the ground. But stationary and tilting the drone manually so I could check the output of the RC channels.

Does anyone have a good tip?
This is the link for the log file: https://drive.google.com/file/d/11B31CWtc8N_3qYAnFM_f10M3Hh2CvWrF/view?usp=sharing


On this lift-off attempt it looks like you have full throttle applied, motors outputs are close to or at max and it’s not taking off. You don’t have battery logging. You need that, at least voltage.
Describe the components on the craft and it’s take-off weight (inc battery).

BTW-I don’t know what Flight Controller you have but fmuv2 is almost certainly the wrong firmware. But, this won’t be the problem here.

The log I’ve added was during standstil without props, to indicate the different outputs of the pwm channels.

I have another log made with props on trying to take off, the log is here: https://drive.google.com/file/d/1NQER7TLHkYZnRciCC-4QC-no-cLaRdEh/view?usp=sharing

What I see in it is a strange sinus on the roll on a low frequency which I can’t explain. Could this be the reason why it will tip?

At the moment I don’t have battery voltage as input on my pixhawk. The motors run on 48V 100kV motors with 30" props. The take off weight of the drone is about 10kg.

It is very easy to make a voltage divider.
If you have a cheap pixhawk 2.4.8 or similar on something with 30inch props you might want to re-evaluate the flight controller choice. It could work fine, but it might not last. Those 2.4.8’s are usually missing the good parts that make other FCs more reliable.

You could use this

or even better
and set this parameter to 75

EDIT: sorry, I thought you said 100 volts, but you said 48 volts - my mistake!

  • In the first diagram the 50k resistor would be 25k.
  • In the second diagram you would use a 24v zener and make the 10k resistor 7.5k , and a suitable offset value in params. The second diagram is an option to using a basic voltage divider like in the 1st diagram.

From that log you posted, I believe the Vcc (regulated 5 volts DC) is too low at 4.45
Peripherals such as GPS wont work reliably, and the flight controller wont be reliable either.
I would set BRD_VBUS_MIN to 4.7 and fix your voltage regulator.
Set up the voltage divider and set BATT_MONITOR,3 and after a reboot you’ll see the rest of the battery parameters.
Use the initial Params section of MissionPlanner to set all the correct battery failsafe levels for you.

When you arm with the props on, does the whole frame shake? Does landing gear need to be more solid?

Thanks for the reply. I will add the voltage divider to the drone for the battery monitor. Does the flight controller actually do something actively with this data or is it just for monitoring?
Good point about the Vcc, I missed that. I will change the voltage regulater.
The frame is indeed shaking a bit, I didn’t realise it would be so important for taking off. But in the data is the high degree pitch visible, without response of the flight controller.

About the flight controller I totally agree the cheap pixhawks aren’t the best. But I am curious if I would install for instance an orange cube if the problems would dissapear. If it is caused by the landing gear or the Vcc I would keep the problem.

These will do nothing w/o battery voltage (linearize motor thrust curve):

Right. And the correct firmware for that Flight Controller is either Pixhawk1 or Pixhawk1-1M depending on the flash size. Not fmuv2. If it’s one of those ever popular 2.4.8’s then Pixhawk1 is correct.