Drone spinning on forward movement at medium speed

Hello Everyone

I am hoping someone here has experience with this - New Cuta Copter 6S with Arducopter FC, on forward movement out to 10-15 meters the drone spins for no reason. I have tried all 3 flight modes and the same result. HELP

Hey @CUTA-COPTER
Share .bin logs.

Hello - Sorry I am a Newbie - Are you saying there is a section I should post this question bin logs?

@CUTA-COPTER you should attach the logs in this thread itself. I am sure someone will be able to help you out then!

Post a link to the .bin log you have uploaded to a cloud service (DropBox, etc.) they are typically too large to attache here. These logs are on the Flight Controller accessible through Mission Planner:

https://ardupilot.org/copter/docs/common-downloading-and-analyzing-data-logs-in-mission-planner.html

1 Like

No problem

100% newbie , it’s ok

Yes it’s 100% work.
Simple way see post your “.Bin” file remove your memory card to your pixhawk -> plugin computer -> APM -> LOGS -> and find your date wise also time wise log when you feel this problem. Peakup and pest here.

Happy flying :slightly_smiling_face:

Hello Dave - Do you know any ArduCopter experts that lives in Perth that I can reach out to?

I am looking for an ArduCopter specialist in Perth if possible - Do you know anyone?

Hello there - Do you know any ArduCopter specialists that live in Perth?