Drone land - drone not disarm and jumps

hey everyone i need some help with my drone,
after the drone touchs the ground in rtl mode the motors rpm slows down and the 1 sec afterward the drone tries to takeoff again ,
i get events of : land_complete_maybe then land_complete and then not_landed
what can i do with the issue?
Version:4.1.2 and 32 inch prop 32kg mtow


Update to ArduCopter 4.3.2-rc1 and check you vibration levels

We need the actual .bin log file to find out the causes.
At least update to 4.2.3, if not the latest stable release.

ok i will upload it,
its on the first land in RTL and then the quad open the motors and i take over to stablize
this is the log:

its it something that can happen from wind?

It’s good that you switched to Stabilize and took control
Part of the problem is tuning, or lack of it. And I think primarily MOT_SPIN_MIN is too high.

First upgrade to a newer firmware version, at least 4.2.3, or latest stable.
Then ensure you have these set:
EK2_ENABLE,0
EK3_ENABLE,1
AHRS_EKF_TYPE,3
INS_FAST_SAMPLE,3

Second, what ESCs do you have? Is it T-Motor Flame, or Alpha, or something else?
For these T-Motor ESCs set these:
MOT_PWM_MIN,1100
MOT_PWM_MAX,1940
and for anything else set
MOT_PWM_MIN,1000
MOT_PWM_MAX,2000

And you will need to redo these values using MissionPlanner Motor Test.
MOT_SPIN_ARM ← set as low as possible but still reliable start up
MOT_SPIN_MIN,0.2 ← too high and part of the problem with not disarming, set to MOT_SPIN_ARM + 0.03

And MOT_THST_EXPO should be about 0.8 unless you’ve got thrust data or something to support setting it to 0.25

Set these:
ARMING_CHECK,1
ATC_THR_MIX_MAN,0.5
INS_ACCEL_FILTER,10
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.17
INS_HNTCH_FREQ,40
INS_HNTCH_BW,20
INS_LOG_BAT_MASK,1
INS_LOG_BAT_OPT,4

Now connect to MissionPlanner and go to Initial Parameters, put in you prop size and battery cells and accept all the changes it offers. Keep all the settings I’ve details above.

Also try different values of GPS_GNSS_MODE, start with a value of 5, but whatever you select only pick two constellations, usually GPS and one other.

You should probably set a switch and channel on the RC transmitter for “Emergency Motor Stop” and set this parameter to match your RC channel.
RCxx_OPTION,31

Now do a test flight with just AltHold, hover for a while and some gentle pitch and roll movements.
Let’s see that log.

The aim is to do some adjustments now, like the Harmonic Notch Filter and anything else we can find, then next do an Autotune.
Later you will probably use Stabilise to test for the fastest safe/stable descent rate and set some more parameters related to that, like LAND_SPEED.
It is not a good idea to be doing missions before you’ve completed tuning.

Some things I saw in the log

GPS and IMU positions rarely agree - this will lead to unwanted movement when landing or taking off.
This is probably do to the GPS unit being overwhelmed by too many constellations, since you have low vibrations. But also using EKF2 is very outdated and EKF3 will do a much better job
image

I think this is the section where the copter landed but didnt disarm and you took over.

Motor outputs for that section of the log, it’s still running at MOT_SPIN_MIN

2 Likes

first of all thank you very much for the detailed reply,
the parameters you have mentioned seems very reasonable to help with the problem i have,
i will go tomorrow for flight and change the parameters as you told me and do some tests,
and btw i use alpha 60 controller,
thanks again

Hey xfacta , i have change the parameters set the mot spin min as low as possible and mot spin arm higher also the mot expo have changed the loiter, alt hold, and guided control on pitch,
so i have only changed to 0.4 instead of 0.8 , in 0.8 the drone was always unstable in forward flight about 2-4 pitch ± and always try to correct it self
i didn’t use the notch filter and firmware
btw the drone change the landing position every time about 2-4 meters
and yesterday in landing with wind about 8-12 knots the drone touches the ground wait 1 -2 seconds and open the motors again , it seems that the drone detect the landing but still opens the motors,
can u have a look again on the log and parameters?
i will add a link below:

thanks again.

Definitely update to latest stable firmware FIRST before updating the params below, version 4.3.3, there is important fixes included.

And definitely set all of these

ARMING_CHECK,1
ATC_ACCEL_P_MAX,25000
ATC_ACCEL_R_MAX,25000
ATC_ACCEL_Y_MAX,10000
ATC_RAT_PIT_D,0.006
ATC_RAT_RLL_D,0.006
INS_ACCEL_FILTER,10
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest
INS_HNTCH_FM_RAT,0.7
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.25
INS_HNTCH_FREQ,30
INS_HNTCH_BW,15
INS_LOG_BAT_MASK,1
INS_LOG_BAT_OPT,4
MOT_BAT_VOLT_MAX,50.40
MOT_BAT_VOLT_MIN,39.60
PSC_ACCZ_I,0.72
PSC_ACCZ_P,0.36

I’ve revised some of these since the last time, they should be close enough for now. Some are to calm down the small oscillations and some to implement the correct values based on things in the new log.
Leave MOT_THST_EXPO,0.4 which seems to work with those ESCs (strangely enough)

The above parameters should settle things down and get another good log to inspect.

1 Like

Despite saying this the wrong way around

you did it correctly in parameters :slight_smile: I had looked for that when I replied last time, but thought I should just mention this mistake in your text (but correct actions) in case anyone else is reading through this.

1 Like