Drone do not takeoff

Hi all, I am currently using pixhawk 2.4.8 and drone F450. I’ve tried to take off my drone in the stabilize mode using RC but the drone just couldn’t take off. Is it too heavy as I have only added an RPI onboard. The motor accelerated normally as commanded by throttle but even at my highest throttle value it does not take off.

I have check props direction, esc wiring and esc calibration. Do i need to increase the throttle value in Mission planner? If yes, how?

Appreciate any help in this and thanks in advance!

Usually unable to take off in Stabilize mode would most likely be overweight. What motors, props and battery have you got?
What is the total takeoff weight?

It is best to see the .bin log file - upload it to a hosting service like dropbox or similar, and share the link.

Have you done the recommended tuning?

And use this spreadsheet to help:

1 Like

@xfacta Hey Shawn! Thanks for responding. I’ve been cracking my head trying to figure out this issue.

Motor: JMT F15843
Prop: 9443
Battery is 2200mAh 3S1P 30C
It should not be overweight issue as I previously fly using APM 2.8 and I only recently switched to Pixhawk 2.4.8. But now i’m just puzzle why it doesn’t take off at all. My takeoff weight is 1.6kg.
I have tried tuning the parameters but - no differences except it vibrates more.

1 1-1-1980 8-00-00 am.bin.log (834.3 KB)

Appreciate for your help Shawn!

It’s way over weight/under powered. That combination of hardware, 3S power and weight would have a thrust:weight ratio of ~1.4:1 Try 4S power if the components can handle it but you would still want to loose a bit of weight even then.

And this is a good example of how useless and outdated the Auto Analysis Tool is. Your Motor outputs were all at max on that takeoff attempt.

1 Like