Servers by jDrones

Downloading of bootloader not allowed in firmware site


(Frankie Fung) #1

Not sure if I post this in the wrong section as I can’t find a more suitable section for my issue.
I am in the process of flashing arduplane firmware to an OpenPilot Revolution board. Have already installed the STM32 bootloader, but still getting error (no response from board) when flashing arduplane.apj to the board.
Suspect ATM32 is not compatible with ardupilot. So I tried to download arduplane with bl.hex in firmware site but when I click on the link, it just opens up with all the binaries, not allowing me to save it to desktop.
I also tried revo-mini bl.hex (in firmware.ardupilot.org/Tools/Bootloaders) with same result.
Plese help.


(Dave) #2

Right click the “with_bl.hex” then “Save Link As”. Then use Betaflight Configurator to flash the firmware.


(Frankie Fung) #3

Thanks for yr help Dave. It worked right away and I managed to flash the arduplane with bl.hex. The ardupilot ran on Revolution board.

I then reverted the board back to Revo firmware to connct to LibrePilot (so I can change some setting, as I can’t change the board setting in Mission Planner). After that I did the same things that brought me to flash successfully the arduplane FW, but many times trying different things, still not successful.

Here is what I did :-

  1. With the board SBL pads soldered, I opened Zadid, chose “List all devices” under Option, then chose STMicroprocessor, and clicked “Reinstall driver” (as most of the times, the driver is already there because the driver is shown in both the left and right hand box). After installation, message shows driver installed successful (see attached). But when checked the driver in the Device Manager, it is not there.

The only way for sure I can get the driver appear in the COM port in Device Manager is to put the board in DFU mode in iNAV or Beta Flight, then click ""Load Firmware(ONLINE), and the name of the file is unknown. This way, the driver STMicroprocessor will appear (see attached).

  1. Having got it in the Device Manager, I then flashed the arduplane with bl.hex in iNAV or Betaflight with the correct COM port shown in top right hand corner of the GUI, but not successful. The driver JUST DISAPPEARED. I also tried to flash the arduplane.apj by choosing Pick custom firmware in Mission Planner, with same result.

I read from somewhere that Chrome sometimes does not recognise the driver in Windows environment.

Appreciate your help. If you


(Dave) #4

I’m not understanding what board settings you can’t change in Mission Planner and what the point is flashing back to Betaflight if you want to use Ardupilot. The settings certainly are not persistent. Maybe I don’t understand what you are trying to do,.