Done tuning or did I miss something?

Hi everyone,

I’ve no problem with the copter (yay!), I think I’m done tuning it, but maybe someone could look at my last log and check if I missed something.
I’m using a 40cm frame, 10x4,5 props, 4S 5200mAh, weight about 900g.
Battery, Failsafes, Harmonic Notch and Autotune was done. I’m using latest with EKF3 on a Mamba F405Mk2.

The log is from a short flight, it was cold and with high wind gusts up to about 60km/h. Flying most of the time in AltHold, some Loiter also.
Log

I would be happy if anyone could point out something that is amiss, thank you.

everything seems good but you have some motor imbalance and its cloud because of strong wind

and its seems that sometimes something hitting your FC or its maybe because of sudden motor RPM changes
it doesn’t caused any problem in your flight but its good to check that

for a better analysis wait for a calm day and do a flight with 1min of hover in loiter or althold mode

Good Luck

Hi Hosein,

thank you. Yes, C3 has a higher value. Have already checked the motor, I see no difference to the other three. I’ll monitor it and when it stays at this range to the others I think it’s ok. Maybe I change two motors and check if it moves or stays at this channel, then it’s the ESC.

As for the vibes I checked the original file and I think that happens when I search/replaced the lat/lon GPS values…Anon Log from Mission Planner didn’t work, the resulting file had still the GPS coordinates in there.
Here is the graph from the original file:

As for the wind, that was a nice stress test, it had to fight hard sometimes :wink:

Here is a log from a longer flight: https://drive.google.com/file/d/1ULLwn5iH61HLhvzkEAZ3IXUovMdV-oY-/view?usp=sharing

I’ve the problem that it runs out of log memory after 2/3 of a flight (the flash is only 16MB). Any idea how or what log messages I can reduce so that a whole flight (~35 min.) can fit?

Hi @Hamstersocke

vibration on Y axis is high and on X is close to max !
check for hard wires or other object to don’t transfer vibration from body to FC
also there is noisy pattern in your vibration that its meaning that you have noise on your gyro


configuring harmonic notch filtering cloud help much

also you can see this noise on motor outputs

and finally these is some little noise on Pitch , after harmonic notch filtering try another autotune to solve this

Good Luck and let us to know how it goes

about log size you can edit LOG_BITMASK value to delist some data to dont record on log file

Thank you. I did the (throttle based) harmonic notch again:

I chose 120 Hz, looks then like this with filtering:

As for the logging, I don’t want to completely disable messages. Is there a way to reduce the frequency of the messages from some sources?

Choose the peak ~65Hz instead, the next ones are harmonics and will be attenuated.

i think it was not an only hover flight in a calm day
is it right @Hamstersocke ?

if its try to do a hover flight in althold mode or loiter and check FFT again

i don’t think its could be possible without editing source code

Will try 65 Hz. One question about the charts: What unit is the amplitude? Before filtering the amplitude @ 65 Hz ACC was 60, afterwards 4, even with the filter at 120 Hz. What’s the reason for this? The BW was 60 Hz.

As for the calm day it won’t get closer to a quiet AltHold. There was very little wind and I applied a small constant correction to avoid drift.
If I would wait for day without wind I would wait forever, there is always wind here. An alternative would be to fly in the garage, but can’t arm without GPS. Can try it again with Loiter outside if that’s better.

if its was small its ok but if you move or try to correct against strong wind you cant find right frequency of hover

Unitless essentially*. It’s only good for comparative purposes. The 65Hz peak is lower from the Low Pass Filter (always there) that you see when looking at Post Filter Data.

*Perhaps a Dev has a better answer for this but I don’t think it really matters. A bit old but from the 2017 Unconference. Go to 16:40 for FFT.

Thank you both. I’ve changed the frequency to 65 Hz and did a short test flight.

if its was small its ok but if you move or try to correct against strong wind you cant find right frequency of hover

Yes, was barely touching the sticks :wink:

However I think I’ll do it again with better weather, had even after a very short hover flight ice building up on the props (it was getting louder than normal) :slight_smile:

That worked nicely…