Do-Digicam-Control

Does anyone know how to get Do-Digicam-Control command to trigger in the 2450 GPS?, i.e. make the camera work under arducopter.

1 Like

I know this was asked long ago, but, recently I also wanted to trigger the camera via mission items.

I submitted a small pull request which adds this missing feature here:

–Brad

3 Likes

Upvote.
Is the ardupilot mod complex? This would be worthwhile because I fly my SV on waypoints beyond range of the Tx and it’s silly to record video all that time.

Not complex at all. Follow the link to see the code. Unfortunately, I can not predict when it might be merged, let alone if it will ever appear in a future firmware update. There are other pull requests waiting to be merged as well with no comment from the repository owners in weeks. This is disappointing, but one of the great things about open source is that you can always build your own firmware.

Do you have instructions on the dependencies and requirements to build the Sonix firmware?
I’ve been trying myself on a fresh Debian install and I’m stuck at where the make mavlink command fails due to missing mavgen.py or that it can’t find it.

edit: Got past that error, either due to sudo-pip to install pymavlink or re-cloning the repo worked, but now another issue but I think I have an idea whats causing that

edit2: now stuck at arm-linux-gcc error on the make command

So is the Do-Digicam-Control mystery for the SkyViper v2450GPS solved here? Is it merged, and/or in updated firmware? Is there an entry-level step-by-step guide to implement the mod @brad112358 so helpfully posted above? What @WinterB added might be exactly what I am asking for but I understand none of it.

Eager to fly again. I think the snows have stopped for the season here in MN…

<thread_necromancy>

Any progress here??? Got a Viper Journey last week to use to experiment with Ardupilot and I am LOVING it – the drone is a toy but an excellent value. One of the aggravating things, though, is being unable to control camera activation in-mission via AP.

The patch above works good for controlling camera in-mission. Thanks @brad112358