Disarming sends motor to full throttle

I am using a Castle Creations High voltage ESC with an Eflite motor.

I get the expected behavior from the throttle when I am in manual and FBWA mode. I do not get the desired performance when I am in RTL mode.

When I reverse the Throttle in mission planner I then get the desired behavior in RTL of the plane going to full throttle trying to achieve its set cruise speed. I then switch to manual mode, throttle down, and disarm. Once the plane has disarmed the motor then spins up.

Any help would be appreciated. It seems the usual ESC calibration does not work with the Castle creations models, is there something special about these speed controllers?

Thanks for any and all input or suggestions.

@Autonomost, a log would be useful!

If it’s anything like the CC for multis, you can’t calibrate them as they have fixed endpoints. I wouldn’t know what they are though…

Apologies. Here is the log tridge.

2016-09-21 08-28-11.bin (3.3 MB)

Will RTL not throttle up when on the ground? I have been reading and seeing this pop up. I managed to get the plane to throttle up no problem with an IC engine…surely this plane being electric wouldn’t change that?

So I went into the ESC itself and checked out some settings. I have the option of fixed endpoints and auto calibration. It has been set for auto calibration so far.

here is a log that shows the armed and disarmed behavior.

This is a non issue


This is a non issue

Does this mean that you’ve solved the issue already, or is this still open? (Haven’t grabbed the log yet if you’ve already sorted out what is happening)

On a side note, I forget why, but I would recommend swapping to fixed endpoints with the Castle ESC. I ran into some problems with auto calibrated end points several years ago on APM 2.5 hardware, but I can’t recall what the issues were (I’m sorry, I know thats about the least useful anecdote but I can’t recall why I had to do that at all). Doing the fixed end point setup is a fairly simple process to do it once.

So the disarming going to full throttle seemed to be an issue with me reversing the channels within the Pixhawk.
I think it’s safe to say that is solved,

I still haven’t done a flight test to determine why it wont spin up in RTL. I just don’t understand why it would throttle up with my IC plane but not with this electric.