Servers by jDrones

Disabling internal compass


(Gerber) #1

Hi,

The internal compass of the Pixhawk always gives a yaw offset of +/- 10 degrees. I’m trying to disable the internal compass by setting parameter COMPASS_USE2 = 0, so heading/yaw will be based on the external compass only (COMPASS_USE = 1).

For some reason the internal compass is still used -> heading will only change when rotating the pixhawk itself. Rotating the external compass doesn’t seam to have an effect on the heading or yaw.

Anyone an idea how to disable the internal compass?
I’m using Rover FW 3.2.1.


(rmackay9) #2

Gerber,

It probably is using the external compass but if you rotate the external compass on its own without rotating the flight controller board, the EKF will see that the compass doesn’t agree with the gyros and start ignoring the compass.