Dataflash Log not recording

Hi All,

I am setting up my first Plane with Pixhawk. I “flew” it on the ground with the propeller removed (armed it and started the motor although the airplane did not move), but there was no DataFlash log recorded.
Even if I set the parameter LOG_DISARMED to 1 it does not record anything on the SD. When I try to download the logs it tells me that there are no log files.
Is there something which I am missing? Do I have to wait until I can do an actual in-the-air flight before it will log anything? I would like to assure myself that all is working correctly before flying it.

Thanks for any help.

You might take the SD card out of the Pixhawk and see if your PC can read it. Possibly corrupted.

Sometimes you need to (re)format the SD card.

Thanks fellows. That seems to be the problem.

I reformatted the 4Gb which came with the Pixhawk with no improvement. Some of the file names were gibberish even after formatting. The PC would not get rid of them because it did not understand the file name. Maybe Chinese?

Then I put in a new 16Gb and voila! all worked perfectly.

Problem solved.

Buyer beware - the chip which comes with a Chinese Pixhawk clone may be no good.