Servers by jDrones

Custom Imagery in Mission Planner

Ok, that information is very helpful.

Thank you for your time and patience as I learn more about one of the many awesome features of Mission Planner. I am amazed by its breadth and depth. Thanks for a great product and for being extremely responsive.

Dave

1 Like

Weird, two Bolands on the same thread!

Alex you can do it with tiles or GEOTIFF both from global mapper. With GEOIFF you must select custom imagery under source in the upper right corner drop down. Then hit CNTL F to get the menu to upload your custom imagery.

I don’t have mission planner in front of me and can’t remember the name of each tile. I can provide more specify assurance when I get to mission planner, which may not be for another 24 hrs.

Once you get it working, it’s awesome.

Dave

Alex,

I doubt it’s related to resolution. I had great results with 2.5cm/pix. File coordinates are crucial.

Dave

Good to hear. I assume you referred to the YouTube video for the original setup? I might need to update it to reflect the moved folder.

Aloha!

I am attempting to load in custom elevation data into Mission Planner so that I can have a better precision than the 100m google earth data. I loaded a 10 m DEM into Global Mapper, following your video tutorial and placing the derived GeoTIFF into the SRTM folder (and removing the other files). When I do this the upper right corner in mission planner says ‘invalid’ and all elevation data is 0. I made sure the DEM was wgs84 beforehand as well. Any ideas on what went wrong?

check missionplanner.log in c:\programdata\mission planner

this should list details about the attempt to load the file

Hey,

I’m trying to make a terrain following flight with my DTM custom map.
I have followed all the stages that you wrote here.

  1. made geotiff 32bit floating dtm from pix4d to MP thru Global Mapper
  2. insert it into the SRTM folder at program data - I saw geotiff elevation data on mission planner right after.
  3. clean the terrain data folder from the pixhawk’s SD.
  4. then write the mission to the pixhawk from the mission planner with the geotiff

And it still doesn’t fly 40 meters above the terrain data from the geotiff,
The weird thing is that it doesn’t fly 40 meters above the SRTM data either.
it flies something between with no constancy.

When I flew there with the SRTM data (before inserting the Geotiff), it flew successfully 40 meters above SRTM terrain data.

If someone knows how to help me it will be great. I’m pretty stuck with the subject.

Thanks

Hi Michael,

Does this internal limit still exist with current versions of mission planner?

I was able to import custom imagery into mission planner my export settings are as follows;

  • Zoom level - 23
  • Number of Zoom levels - 18

This was done using global mapper. If you could please recommend a software that could provide a higher number of zoom levels.

Thanks

The internal zoom limit would be 21 or 22. Anything above this will not be used

Thank you, Michael.

You have a great day ahead.

Hey Michael,

While I have your attention, is it possible to insert more than one custom map in mission planner? I wish to have max 3 atleast 2 custom maps in mission planner that show the following;

1 - google map tiles custom map.
2 - a DEM in a google map tiles format.

Thanks.

do you know if your DEM format is supported by gdal?

MP handles imagery and DEM seperately.

Normal the DEM would be in GeoTiff format, and only requires copying the source image into the correct folder to work.

The DEM which is in geotiff format is copied to the SRTM directory. How do I find out if my DEM format is supported by gdal? I wish to have the ability to display both the google map tiles of a surveyed area and the DEM file to the pilot using mission planner to plan a mission.

Thanks.

Hi Michael,

I can confirm that my DEM which is in the format of geotiff is supported by gdal.

Thanks.

check this post

1 Like

Hello, there is a problem with my TIF file ? Selected option on Global Mapper like in the video

your image is not in wgs84.
looks like its in some other coord system

This is the parameters of Global Mapper

change the projection to Geographic

1 Like

It works well ! Thanks :slight_smile:

Servers by jDrones