CubeOrange does not get recognized

I can’t get ArduPlane to run on CubeOrange. After installing it does not connect. I tried different versions especially 4.1.6, still it doesn’t work. For installing i used MissionPlanner and QGroundcontrol. Afterwards i installed PX4 without any problem on the same Cube. Then i tried a different one that is also new and it worked directly without any problem. From how it looks to me there is no problem during installation. At least no error. But then i can’t get a connection. Why is that happening? I have the cube here and if there is debug information i can provide please tell me.

Seems like a driver issue.
Mission Planner comes with some drivers.
Are those installed properly?
I recommend you do a clean install.
Looks like the cube is fine.

I tried on different computers linux and windows, without success. Also i have a second flight controler also CubeOrange that gets recognized without any problems. Also after a fresh install the problem still persists.

What is Device Manager showing once you plug in the Cube Orange?

Would be great if you could post screenshot of:

  1. Device manager with the working Cube connected
  2. Device manager with the other cube connected

Also, do you have an SD card installed in the Cube?