Cube orange+drotek sirius f9p [solved]

Hi boys.i have drotek sirius f9p rover with rm3100.when i connect it to gps2 port,gps is not working.rm3100 i detectect and i have 3 gps.when i switch serial 4 to mavlink i loose 1 compass.not sure now internal or uavcan one.gps work nice on serial 1 and 2.but then i have no rm3100 then.its cube orange and 4.0.4 firmware.i wanna just know that its only progress implement issue and developers work on it or anythink else.thank you.

F9P and RM3100 are both supported. So it should be something in your configuration. The GPS2 port is probably the correct one to use.

I read that is supported.but its not working on serial 4 for any reason.somebody writed that have some issue as me.thats why i tried serial 1 and 2.more important for me is rtk.but it will be benefit keep working rm3100 as well.

Done it a while ago, it wasn’t working for me on GPS2 either. I am on Cube black.


@Corrado_Steri what was the solution then ?

Plugged it on GPS1 :slight_smile:

Ok.thank for advice.i will try this evening.

Tried on gps1 and same result as before.

Read your post again, did you set gps protocol for the port and baudrate at 115k?

Did you load the configuration file on the GPS as indicated on Drotek pages?

I set baudrate to 115 and protocol to 5(gps).also gps recognition to works on serial 1 and luck serial 3 and 4.i tried set diferent baudrate too.i didnt manipulate conf file on gps via seem to be ok.but.its first time using it.maybe i am wrong.thats why i asking here.

On Drotek site there is a tutorial on how to configure it and a configuration file. Maybe is better if you take a look.

Did you check if the serial 3 & 4 work with something else attached to them?

I have the same configuration like you Sirius + Cube Orange. It’s working on GPS 1 connection. I had problems on GPS 2 connection. How did you connect the wires ? Does the gps works when it’s connected by USB to U-Center ?

Yes.i read that.maybe really need upload firmware first.i had configured storm 32 on serial1 and mavlink2 on serial2 before.all works good.even f9p work nice on both.just rm3100 dont at same time.

I did true uart1 and uart2.i use pixhawk 2.1 pinout page.

Its works on usb port.rm3100 its working on your setup as well?i think that i miss somethink as i ask here.i get it few days ago.just getting familiar with this kind of hardware and all about ppk and rtk and all this work.

RM3100 uses the i2c port present on the gps1 port on FC. If you hook up the gps on any other port that doesn’t have i2c than the rm3100 will not work.

You right.this is how it work i my case.i have to separate this pins and connect to different ports.iam i right?

Yes, if you connect your gps to a different port than gps1 than you have to split i2c, correct.

Your previus answer explain a i understend.gonna find more info.thanx a lot for you time guys👍

I just may confirm that it works on serial3 at 115baud.both of them.i just find out that i incidently swap sdl and i have 2 gps’s and 3 compasses.thank you guys again👍