Crashing during terrain following

Dear all,

Sorry for creating topics back to back.
While I test the terrain following with y6 frame, the drone keeps crashing on the terrain.
Could you help me to resolve this issue?

I run the mission below on SITL, and you can probably reproduce the issue as following steps:

  1. ./Tools/autotest/ -v ArduCopter -f y6 --console --speedup=10 -L Karuizawa
  2. param set WPNAV_SPEED_UP 50
  3. param set WPNAV_SPEED_DN 50
  4. upload and run the mission

You will see that the drone is stuck in a location.

Testing version: Copter V4.1
Mission and log files:


Thanks for the report. I ran the mission provided with a quadcopter (in SITL) and it flew fine so I think this could be purely a simulator issue caused by changes to the virtual Y6 which has led to an extremely poor tune of the vehicle. Below is a graph of the RCOU message and we see the outputs are bouncing up and down.

We’ve seen this problem on other SITL vehicles but I thought I had corrected all the various vehicle’s tuning… apparently not so I’ll have another look.

1 Like

Thanks for your work!
If I want to tune y6, is it the right way to adjust ATC_RAT_YAW_P and ATC_RAT_YAW_I?
Or, should I tune another parameter?


I’ve created a PR ( which greatly improves SITL’s y6 tune and I re-tested with the mission you provided and it seems to complete OK.

Txs for the report!

1 Like

Thanks for the quick patch!
It looks so stable :slight_smile: