Crash Analysis_Copter4.0.3

Hi all.
I would fly in “Auto” mode But the autopilot refused it. So I had to fly manually. Mode changed to “RTL” during the flight and I changed it to “Stabilize”. But it seemed that the motors were turned off and my drone fell for a moment!
Can anyone help me, please?

Here is my log:

@A_manafi Hi,
your system is condiction is good.
This happened because of a manual error, for my observation.
RC3 i.e Throttle is at min position some nano sec.
To eliminate manual errors you do follow some rules.

  1. Use GPS or Pos assent mode like (loiter, PosHold etc)
  2. while you are using Stabilize mode, you won’t down your throttle below its hover point. Mid throttle is always safe

thank you

Thanks for your answer.
But my throttle was middle and above during the flight.
It seems that another problem has occurred. In the figure below, the throttle stick was at the minimum at different moments. Why?

Hi,
seeing how quickly RCIN.C3 drops to 1062, my guess would be tranmsitter or receiver failure/ bad sticks. What radio transmitter are you using ?

I 'm using RadioLink AT9.
After the faliure of the radio the failsafe must be triggered. But why didn’t?

Can anyone help me, please?

change the TX and RX maybe those are problems in your system. USE fsi6 or qX7 etc

Could be radio interference, bad contact on the throttle stick …
You should try to generate logs without props to see if your throttle input regularly twitches in the logs like in your example.
If you can repeat the problem in this way, try changing your transmitter or at least the joystick as suggested.

Found this about your radio :

In particular :

I think the problem was that 15% PWM value to engage failsafe condition.
It is still on throttle value while armed so the fc will not be armed because that pre arm check on failsafe throttle value. Because of this, failsafe condition could not always happened when the Tx turned off.
I think motors stop condition when I turn off the Tx was indicated the Rx didn’t get any signal and stop giving PWM value to FC and FC stop giving signal to ESC because FC didn’t know that it is failsafe condition that pilot wanted.
I even moved away the aircraft more than 2 meters and it was still happened. Motors just stopped quickly and it is not like Landing Mode (default setting on failsafe) that still spinning while decreasing speed until stopped.
Imagine theses aircraft’s motors just stop in the air while radio lost.
This is a pilot’s nightmare.
But I finally get the answer from another user.
It’s a shame that Radiolink themself can not help directly on this thread.
The answer was you must define failsafe condition PWM value on AT9 lower than 15%.
It can be reached if you:

  1. On AT9, enter menu “End Point” and set Ch3’s end point (Throttle) from 100/100 to 100/130 or 100/140. Exit menu.
  2. Then enter menu “Failsafe” and activate F/S on Ch3 while throttle stick lowered to minimum then pushed and hold center button (Center of Dial Button) for 2 seconds. It will showed you that F/S on Ch3 is lower that 15% (around 3% or lower). Leave this value. Exit menu.
  3. Enter again on menu “End Point” and revert back Ch3’s end point as 100/100. It is done.
1 Like