Servers by jDrones

Crash - ALT_HOLD - Drone climbs, no throttle control

crash
throttle
lidarlite

(Kilo November Delta) #1

Hello everyone,

I did an experience yesterday, and unfortunately it ended badly.
The objective was to stabilize again the drone with the ZED camera (which succeed the day before).
During the test, the drone was climbing without ends, even if the pilot was in ALT_HOLD, there was no answers from the throttle command (only angles reacted).

After analyze, I saw there were an error from the lidar, which believed the drone stayed at the ground during the flight (I suspect a wiring problem, but not sure for now).

The scene happened like this, from the pilot point of view (throttle is normalized between 0 and 1)

  • BEFORE TAKEOFF
    ALT_HOLD mode, unarmed
    Arming, throttle = 0
  • TAKEOFF
    Throttle up, climb to 1.8 m
    Throttle = 0.5 in order to stabilize
  • LOST OF CONTROL
    Throttle down, then fully down = 0. Drone continues to climb.
    Change ALT_HOLD to GUIDED, then go back to ALT_HOLD (think not in the right mode)
    Lost of control detected in altitude. The pilot crash the drone in the wall by purpose, to avoid the light on top.
    CRASH.

What I don’t understand, concerning the altitude, is why the drone still climbs, even if the throttle is at 0. Even if the altitude believed by the drone is wrong, thinking it’s on the ground, it is not supposed to have this behavior.

Here is the graph of the altitude desired that I do not understand :

Is someone can understand what happened and explain to me ? And, if possible, provide a solution to avoid this ?

Parameters :

  • LidarLite V3, PWM
  • ArduCopter V3.6.6
  • EK2_ALT_SOURCE 1

Thanks in advance for your time and your help !

12.03.2019 Crash A to B.log (445.2 KB)


(Kilo November Delta) #2

A little up

Your help for the understanding is valuable to me :slight_smile:


(Shawn) #3

have you got a .bin log we can look at?


(Kilo November Delta) #4

Yes of course, here it is :
14 01-01-2000 01-03-52.bin (232 KB)


(Shawn) #5

Just having a quick look so far…

  • Vcc is low and a bit unstable, at about 4.65 volts most of the time and dips to 4.5 about when things start going bad. It should be around 5.0 volts or up to 5.2 and much more stable.

  • Vservo voltage almost matches Vcc which says you might be powering the flight controller from a ESC BEC, or connecting your Vcc to the servo rail to power something else ??? Either of these are probably bad. If the Vservo is totally separate from Vcc then that’s OK.

  • Power external devices like rangefinder from a BEC, dont use the flight controllers Vcc.

  • The battery voltage drops almost immediately down to your failsafe level, as if you’re starting with a depleted battery

  • Vibrations look OK and dont seem to be the cause

  • Baro altitude just keeps going up, is this indoors?

  • Configure Stabilise flight mode, at least for testing, this way the motors will definitely follow your throttle commands. If Stabilise is working well then switch to AltHold and Loiter (and so on), come back to Stabilise if things go bad.

I’ll keep looking, but maybe those more experienced than I can take a look.


(Kilo November Delta) #6

Thank you for the analysis !

To answer to your question :

  • Indeed, the drone is too heavy for now, we are going to optimize it later. So it is normal that the voltage drop suddenly after arming. But I don’t think the problem comes from it.
  • The Vservo is powered by a BEC, to give power to the lidar (which is plug in the servo rail of the Pixhawk).
  • The baro altitude is correct, we drone climbs to 10m indeed in indoor environment. And that is precisely the problem, even if the Lidar is wrong, why the drone climbs even if the throttle is at 0.
  • Next time we will keep the Stabilise mode in backup if the altitude desired of the ALT_MODE goes crazy like this experience. Thanks for the advice.

(Oldgazer) #7

Voltage should not drop all that much just by arming, so something else is wrong here…
I don’t power anything from the servo rail. I run external power directly to each accessory…


(rmackay9) #8

I think the problem may be caused by having a bad lidar (the altitudes are not matching the baro at all) and also having EK2_ALT_SOURCE = 1 (for range finder). It is normally not a good idea to change this parameter from the default (0 for barometer) even in cases where the desire is to have the vehicle maintain an altitude above the terrain. There are a few warnings here and there regarding changing this parameter but I’m tempted to make it an arming check.


(Kilo November Delta) #9

All right, so I will change the EK2_ALT_SOURCE, and set = 0. And keep a Stabilize mode flight as a backup, if the issue is reproduced.
I will double check that the wiring was in cause, and hoping that the problems does not appears again.

For the voltage, I will check if all the electronic circuit are ok, and the battery is not damaged.

Thanks guys, you answered to my question !