Couldn't shut off motor! Lost control over RC Out! help!

I am flying the newest version of trad heli on a trex 800.

I had a weird case yesterday when I took off in stabilize, tested alt hold, and then tested loiter. Upon landing again (in stabilize). When I landed the heli, I couldn’t control the heli at all, the dataflash logs show that there were no changes in RC input after landing but that is not what happened. The heli just sat on the ground spinning the motor and I couldn’t stop it. We tried changing the RC8 max through the telemetry and that did nothing to help the problem ( I am running mode 1 for a governor), this is after we tried to disarm the heli through mission planner. It said it disarmed (hence the two telem logs) but the motor continued to spin! We couldn’t rearm it because it said “motor not spinning”.

Please help me understand what happened! I ended up just waiting for an LVC and disconnecting it. I believe this may be a weird edge case that messed up the code, the only other thing I can think of is it was hot outside (about 100 Fahrenheit). Can someone please help me decipher what this could be, I need to continue to flight test but I can’t until I’m sure it won’t lock up like this again in flight.



Looking at the telem log, when we disarm the heli channel 8 output drops from high to low, and we can’t arm getting message “arm: rotors not spinning”. But trust me, they definitely are.


I had a look at your log, and am not yet seeing any problem.

I do wonder what your RC Rx failsafe settings are? Have you ever tested them. Maybe they hold on to the last value after loss of link?

The “rotor not spinning” thing is actually false, the message should have said “rotor is spinning”. So in this case, it wasn’t letting you arm because it thought the RC8 was high.

I don’t think this is a tradheli specific problem, nor an “edge case” that has something to do with your flight. I think it will end up being either a user error, or some deep bug in the code. I’ll try to get Randy to help have a look.

I do see one slightly curious thing. Your Servo Rail voltage also flatlines after you land. I’m not sure if this is because the servos stop moving? Or a sign of something else. I also notice that before you take off, when the servos are moving only very little, the voltage is mostly flat, but not totally flat like it is after you land. So it almost seems to indicate the servo rail voltage measurement stopped?

I also see that in the PM message, you have a about 3-400 NLon throughout the flight, but then it drops to about 100 after you land. I’m not sure yet what this means either.

What worries me about this failure is that it happened right at landing, like exactly. Am I just the luckiest person on earth or do you think it was a landing impact knocking something loose? or a landing detector issue?

I will check the temperature rating of the BEC that powers our pixhawk servo rail and see if we could’ve exceeded it.

What concerns me is that we changed the Ch8 maximum to the lowest setting, and its trim to the lowest setting and the pixhawk said it accepted the change and nothing happened. And when we disarmed the pixhawk nothing fixed the problem.

In the logs you can see RC8 go to low, this definitely wasn’t passed through to the esc because the motor never stopped.

We also had no RC input after we disarmed it, unsure if it was before, be aware that I was moving the sticks the entire time after landing. We went to radio calibration to look at the inputs and it was still dead, the rx was still plugged in tightly on landing, and as long as the pixhawk is getting enough power to log it should be powering the receiver correct?

If its a user error, I hope we can identify it, I am going to stay grounded until I can figure out a little bit of what went wrong

Ran everything up and then yanked the power from the servo rail, the ESC shut off.

Ran it up and turned off transmitter, motor kept spinning as expected.
However then I lowered the RC8 max to 1000, which we did during the original failure, and that stopped the motor. That did not happen at the field the first time.