Copter wants to flip on takeoff please help

I have a tarrot hexacopter 6axis with cubepilot orange. I see it trying to flip to one side on takeoff. I have checked all blades for the correct direction, motors correspond correctly to fc. Can someone review ny bin and help me out here. I am a newbie if you can’t already tell. Thanks!

1 Like

Have you run a motor test? If so - do the motors spin sequentially going CW around the frame?

When I do motor test all i hear is beep with no spin even when I increase throttle %. When I click test all motors they all spin. Somewhat frustrating to say the least

Why do you have this set to 1520?

If you are using PWM just set MIN and MAX to default (0)

Just different forums I’ve read describing the same scenario. I’ve been messing with this for weeks before I even posted. So set these to 0 which is default is that what you are saying?

Yes. Why would you want Minimum PWM to be at mid throttle? And don’t attempt to fly it if it fails Motor Test, you need to resolve the problem 1st.

I agree, not for sure how to approach the motor test issue. Any ideas why individual test shows no results, but all motor test works fine.

One simple way if you not using Dshot is to run the esc calibration. Make sure your Props are off! Calibrate the radio as well.

I did all this running hobbywing xrotor pro 50a and radio is calibrated as well

Well, 1st reset those parameters, then do an ESC calibration, then see where you are.

Ok still no results but a single beep after setting pwm correctly and recalibration of esc and radio. I did however notice ekf was in red when I clicked back over to data during motor test or attempted motor test

That will have no effect on Motor Test. What throttle percentage are you trying? Set it 15% or so and 10s. Props off obviously.

I have set it to 15% throttle and 10s. Still nothing so I increased to 20%… Nothing. Tomorrow im going to measure output on main out pins to seee my voltage. Motors spin when armed but only when I arm the motors. Nothing on. Motor test, only when I select all motors at one time under motor settings do i get activity. It could just be me, but it seems like a possible parameter setting. Is it possible to have the servos set to aux out instead of main out on cubepilot orange?

That is possible but you don’t. Your motor outputs are configured on Servo out 1-6.

Go the “Data” screen and check the box marked tuning on the bottom of the screen. It should be right beneath the map where lat long is shown (highlighted below). Then, double click on the graph that pops up and plot Ch1Out - Ch6Out.

Then, go to the motor test screen and set motor to 20% throttle for like 15 seconds. While the motor test is running, go back to the “Data” screen and look at the tuning graph. The PWM should go up for the motor that you are running the motor test on. If it doesn’t then the motor test is not outputting signal which is odd - might be the safety button preventing it. You can plot other Ch Outs if you think motor test is sending signal to the AUX Out ports.

I figured out what was going on with the motor test. The black and white esc that connect into the tarot frame was making a constant connection with m1-m6. So I connected directly to fc and worked perfectly for one exception. Motor test A-C went perfect. D motor test nothing but when I click E motor test it runs the 4th motor. See i dropped the hexacopter into a quad only using 4 axis. Why is this? Only 4 servo 1-4 are enabled. Also i changed the frame to quad, so I’m stumped

I don’t understand what you are saying here. If the FRAME_CLASS is set to Hexa, Motors are configured on Servox outputs 1-6 and you have the motors connected to the 1st 6 main outputs then A-F should run the motors in sequence. If it doesn’t you have something else wrong.

I feel like I’m starting to make progress with everyone’s help. My only other issue is that when I arm and the props begin to spin at arm speed everything is spinning correctly and at correct rate it seems, but when I begin to increase throttle to take off i noticed motor 3 slows down to a complete stop while the rest of the props are going the exact same speed. When I reduce the throttle back down to stop all props and increase again motor 3 picks speed back up until what seems like i get past a certain throttle position then motor 3 seems to disengage. I have recalibrated esc again, replaced motor with another with no success. Any ideas?? Thanks for all the patience and all the guided help!

It seems like my yaw is off or pitch, I’m not for sure which one. So when I move the right stick (not the throttle stick) motor 3 starts to increase again, but then motor 4 slows down. Just another update…

My yaw is showing 264.45 when disarmed?