Copter very twitchy after autotune in 3.2

I have a 650 quad with 12" props on 700kv motors that felt pretty smooth with stock settings. I ran the autotune and it became very very twitchy. I backed off RC feel and roll/pitch sensitivity but it still feels very twitchy. Any advice? Should I take RC feel lower? I can’t lower roll/pitch anymore. Should I try autotune again?
I’ve included screenshots of my current pids and rc feel settings below.

there is a known Auto tune issue in AC3.2.
just set down D value from 0.02 to about 0.01 or a little bit lower 0.008. As much as needed to stop twitchy.

Thank you Pomaroli I did not know about the 3.2 autotune issue. I’ll look into that and try the D value you suggested.

Pomaroli, what exactly is the “known issue” with autotune you are referring to?

Flyhigh, I would recommend running the PID’s as autotune came up with, including the D-term. It’s not a good idea to reduce D-term without also reducing the P-term… now you’re doing a full manual tuning job which most people are not good at.

As I said, I would recommend using the autotune pid’s and then try enabling the Accel Daming Feature. Try setting these numbers:


See if that makes it feel better for you.

Hi Rob to set Down “D” value is only a workaround, i’m not saying i’m happy with this. It worked for me.
But still there are more people noticing some strange behavior by using Auto Tune since AC 3.2.

See also this other tread leonard was commenting too :

i don’t use the ATC values, they are disabled and if possible i would like to leave it this way. Some of the values you have wrote are out of range, did you try out in practise ?

At first, using the Y6B parameters, I couldn’t keep the copter controlled enough to even do Auto Tune, so posted at DIYD. Between Rob and Leonard I was able do AT.

My Spy 750 PID’s are maxed out. Leonard said he’d never seen that before and that AT would see improvements in the next release. … 4#comments

It had Yaw issues for which Leonard advised changing some Yaw and Loiter settings. I did and it worked, but eventually figured out what prop combination worked best and reset them to default. I reran AT but it still put the PID’s at max.

The copter was flying much better, but seemed to have some twitching with no stick movement so I set the Yaw D Rate to 0 and it now flies very well, even in windy conditions, however still needs some fine tuning. I’ll wait for the next release to see how AT works.

Rob, would you recommend changing the settings you listed for my setup?