Copter suddenly unstable and uncontrollable

Hey guys,

I’ve got a strange problem with my quadrocopter.
It startet some days ago after I crashed not really hard but hard enough…
I had to replace an esc and decided to change from 4 SimonK escs to a really small 4in1 system (Racerstar Tattoo_s 25Ax4 with blheli_32).

So I made some tests and flights and all worked pretty good.
Now I crashed again but have no idea why.
The flight was nearly perfect, I changed from stabilized to loiter and back and the quadrocopter was very stable.
Then suddenly it staggers but then all was fine again. I changed in RTL mode and the copter was not to control anymore and crashed…
I checked in the logs compasses, gyroscopes and gps but could not find the problem.
Maybe someone can help me and explain why? Maybe I’ve got a loose contact on my pixhawk or something like that…

Here some details to my setup:
600mm quadrocopter (x-Frame)
CopterVs. 4.0.3
Racerstar 4in1 blheli_32 running dshot600
emax 810kv motors
Pixhawk 2.4.8
Only using the extern compass integrated in my GPS module (ca 15cm above all other components)

Here is the log

It would be really great if you can help me or have some tipps. I’m not really experienced with things like that but it makes so much fun :smiley:

This appears to have started with motor 3 being commanded to the max followed shortly by motor 4. The command oscillation of these 2 motors caused a general lack of thrust and down she went. Check the thrust components (motors, ESC, prop) of both motor 3&4. It’s not advised to use Dshot over 300. Actually the Wiki says 150 which is what you should be using. You will not realize any advantage in a “faster” protocol with a craft that size.

Thank you very much!

I change dshot to 150.

Is there anything better I can do to check the motors and escs?
I checked the props. They are okay.
I used the motor test in Mission Planner and tested at first each motor to 90% and after that all at once. No problem…

You could set some of the basic tuning parameters for your craft.

Thanks, this site is new to me.
But I don’t think that one of this parameters will solve my problem…
But I’ll test it

These are basic pre-tune parameters that should be used regardless of a performance issue. Load firmware, set these, go for a maiden flight.

HI, what was the final solution?

Very similar happened to us.
First the loiter mode was not stable enough (we set a lot of safety mode on the controller switches) - brake mode didn’t fixed the copter, later the landing mode didn’t worked. we were stupid - tried another take off and it got completely uncontrollable. flew almost to us later increased the weight to 20 m and crashed from there possibly the virtual fence was not sensed neither - completely not reacting to the remote’s command. Even on the land the rotors tried to rotate. Cuav + ardupliot hasn’t sensed the crash ESC completely burned…

What was your solution?

That seems like excessive vibrations were preventing that Land mode from decending and causing general instability.
You’ll need to post a link to a .bin log file.

I checked several log files and although the vibration figures are not nice (we are working on it), but the former flights logs show similar values. I will publish soon the log.
Thx. Sz.

I forgot to send an update.

I reinstalled the firmware and used the pre-tune parameters as dkemxr said.
And I changed the battery. I think this was the solution for me.

The drone flew several times before the crash happened and flew really stable so the parameters can’t be really the problem.


Here is the log file



X and Y vibrations are still bad, need to balance props and make sure everything is secure.
Z vibrations are absolutely crazy, like your aircraft is shaking itself to bits.
How have you got that flight controller mounted?
Maybe post a couple of photos and some more details.
You Baro readings are like props are really close to the flight controller.

This is the tuning guide:
and this spreadsheet makes it a bit easier:

Set these according to the spreadsheet for your battery cells, also plug in your prop size for other values to use.

Once you fix the vibrations and whatever is going on, provide some more details and a new log file.


Thanks for your prompt answer.
The vibration was suspicious for me, therefor I already started some modifications.
on the attached photos you can see:

  • I tried to lead the high current cables as far as possible from CUAV…(internal cabling.jpg)
  • Also I applied some vibration decrease rubber.
    - under the motors,
    - and under the CUAV.
    (although I have some strong doubt that the
    soft light blue rubber will cause stability issue)

I also attached a picture (former layout.jpg) which was the former build.
there the CUAV was fixed with Velcro and the high current cable were quite close to cuav (which could cause interference with the compass.)


I tried to share the pictures via OneDrive- I hope it is visible!AotAJyqLFfNV7Vd4HBxWI9sZeoeJ?e=w0K0De

I also compared the params you sent (thanks again), and they were quite OK.

The original file was copied to the same place were the picts are.

Almost I’ve forgotten to mention. I made this parameter settings after the problematic flights. Earlier the standard values were in for 9 or 10" props.

I experienced something extremly strange. I contacted the flight controller to the PC with a simply cable and in mission planner I have seen that the horizon and the compass is completely instable, while the machine was completely stable. It was not very close to the computer. I made a video with my phone, it is in the previously mentioned shared folder.