Copter spinning left and right when pushing yaw axis stick

[attachment=0]20150124_222048.jpg[/attachment]Hi Gent,

I built a X quadcopter with APM 2.6 with QUAR GPS COMPASS, during trake off is level and stable but once i pushing the yaw stick to left or right the copter will start spinning wont stop event let go the stick ( spinning follow the yaw stick push direction). i already did several time of initial calibration on the Missing Planer but still the same and PIDs also did some adjustment but also same result (spinning).

here are the video link.

-ESC calibration done. skywalker 40a ESC.
-prop direction correct (1 & 3) (2 & 4).
-motor angel 800kv

Can anyone help on this? i really try out all possible method but still same.

Thanks in advance.
Wlliam yaw

Videos are nice, but tlogs and/or data flash logs are much more useful to help troubleshoot your issue.


Is it the below info? and im have attached a log file, could you please help to review , cause i really no expert on review of the log data

Log File C:/Program Files (x86)/Mission Planner/logs/QUADROTOR/1/2015-01-25 00-41-27 45.bin.log
Size (kb) 84.9580078125
No of lines 1536
Duration 0:00:00
Vehicletype ArduCopter
Firmware Version V3.2
Firmware Hash c8e0f3e1
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = GOOD -
Test: Compass = GOOD - No MAG data, unable to test mag_field interference

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = GOOD -
Test: GPS = FAIL - Min satellites: 0, Max HDop: 99.99
Test: IMU Mismatch = UNKNOWN - No IMU log data
Test: Parameters = GOOD -
Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = GOOD -

millions thanks.
William Yaw

Are the props on correctly motors spinning the right way?

Hi Gary,

I was follow the direction as attached.

OK, but are they actually doing that and are the right way up? (Writing to the top)

Hi Gary,

It is working correctly, I thinking I found where is the problum is,

When I push yaw axis to left the motors 1 & 2 speed are slow than motors 3 & 4, I think these is normal to make the copter turn but the problum is after I let go the yaw stick the motor still runing in slow speed. I very sure this is the cause of the copter spinning. (Normally after let go the stick motor speed should go back all the same speed right).

If push the yaw stick to right the motor 3 & 4 speed will slow than motor 1 & 2 all the way even let go the stick. ( it is Same situation)

Do you have any idea where go wrong? Is that any setting on the apm 2.6. Or the controller?

Thanks a lot
William yaw

Posting a dataflash log will help people diagnose your issue.

But yes with centre rudder stick the motors should return to spinning the same speed, in the air at least. they might not on the bench as the brain might have some desired yaw angle it can’t achieve until take off.

Then it could be a flipped compas ? Because if you will change your Yaw to left, and compass will read it otherwise ,ti will try to correct this error by more spinning causing error to grow.

Hi gents,

Thanks a lot I will try to get the log data and upload. And also re-calibrate the compass again.