Servers by jDrones

Copter overshooting waypoint in AUTO mode


(Kenji Stinson) #1

Hi all,

I am having issues flying a clean preset mission in auto mode. The copter does a fairly good job going from waypoint to waypoint but it always overshoots the waypoint by about half a meter and backs up to correct it self before executing its next path (See attached image).
Does anyone have a solution to minimize these overshoots?

I am using a Pixhawk 2.1 with the most recent APM stable release. I am using the MarvelMind indoor navigation system instead of a GPS.

Thank you,


(henrik04) #2

Perhaps the wpnav speed is too high and the disk brakes not very efficient?:slight_smile:
There is a parameter for the precision which is 2 meters ( by default ).
So perhaps reduce this parameter and insert intermediate speed change commands before and after each wp…

I do this for precision photos and it works a treat.
Henri