Copter not taking off in any mode

We are always getting this message when we try to takeoff, can someone please help us with the same. The hardware for the FC is Pixhawk with Arducopter V4.1.1 and MAVProxy V1.4.86.
The drone works when used with the RC but fails when MAVProxy commands are sent. Not using SITL
Please help

Please provide a .bin file.

Where can I find the .bin file on linux ?

I have the .tlog file
mav.tlog (154.9 KB)

You are in stabilize mode. Change mode to guided.

I am inside a building in a Lab it does not get a GPS Lock I am also trying the same thing in GUIDED_NOGPS mode but its still giving the same error

Takeoff requires GPS unless you have some other positioning system.

Thanks Manav I will try to get a GPS lock

The issue still persists even when we tried to get a GPS lock and takeoff it failed

The .bin log file is also sometimes called dataflash log and is stored in the SDcard on the pixhawk flight controller. You can either use Mission Planner software to slowly download it, or physically remove the card and inset it on a PC to read it out.

Please provide the .bin file. you clearly miss-configured something. Copters with GPS lock takeoff just fine.

2022-01-24 09-21-24.bin (416 KB)

2022-01-25 11-44-02.bin (446.1 KB)

Are you sure this is the right log file? It’s not even configured. FRAME_CLASS isn’t set and there are no outputs configured. Also, it’s not Copter 4.1 where you have posted it’s 4.0

2022-01-20 11-23-58.bin (923.5 KB)

Please read the wiki. You can start here:
Tuning Process Instructions — Copter documentation
and after that is done go here:
Managing Gyro Noise with the Static Notch and Dynamic Harmonic Notch Filters — Copter documentation

1 Like