Copter Non GPS navigation with mavlink

Hi,
I’m following this guide: Intel RealSense T265 — Copter documentation
but I’m stuck on the python part. I installed everything and figured out how to run the scripts: t265_example.py and t265_test_streams.py are returning position data as expected but t265_to_mavlink.py give me the followings:

INFO: Using default connection_string /dev/ttyAMA0
INFO: Using connection_baudrate 57600.0
INFO: Using default vision_position_estimate_msg_hz 14.0
INFO: Using default vision_position_delta_msg_hz 14.0
INFO: Using default vision_speed_estimate_msg_hz 14.0
INFO: Using camera position offset: Disabled
INFO: Using compass: Disabled
INFO: Using default scale factor 1.0
INFO: Using default camera orientation 0
INFO: pyrealsense2 version: 2.50.0
INFO: Starting Vehicle communications
Alarm clock

“Alarm clock” seems to be an error, but I can’t figure out what does it means.

The error is raised on the first attempt to use send_msg_to_gcs(‘Connecting to camera…’)

if I change the connection string with a dead one, it says it’s dead but then connect to camera and shows confidence output, but of course I don’t get VISION_POSITION_ESTIMATE on mission planner

Do you have any suggestion?

Hi @FaMaFortesque,

If possible it is easiest to use the pre-built image for the RPI4 (or RPI3). This will get around all the setup problems I think. Also I would recommend using Copter-4.1 instead of 4.0.

Hi @rmackay9,
thank you for your help. I already tried the pre-build image, but it didn’t boot at all. I can try again from the moment I have now a mini HDMI cable.
I will update to Copter-4.1 too.
I’ll be back.

It’s been a while. I tried again using pre-build image for the RPI4, it boots and I can login to apsync with no problem.
I updated to copter 4.1.2.

I get the same I previously had on MissionPlanner, “PreArm: VisOdom: not healty” and I can’t find any info about that on the internet.

Of course it has problems recognising where it is using camera, but there is no clue on the effective reason.

Do you have any firther advice?

Thank you,
FaMa

With the use of the pre-built image, the original issue has been bypassed, so I opened a new thread for the “PreArm: VisOdom: not healty” issue.

Thank you for your help!

Even with pre-built image I’m stucked on the same script. This time I get “Connection Error! Retrying…”
If I use /dev/ttyAMA0 or /dev/ttyS0 the error show up because after 30 sec the script abort. With other ports it just spam it.

Any hint?