Copter hard crash

Hi all,

I’ve suffered a crash this afternon with my hexa and I realy don’t know what happened. Just after take off my drone turn and take altitude motor turns really hight (full throthle for me). So my setup Orange cube + t265 + RPI + dji air unit. All this setup works, I’ve done a lot fly before this one, AltHod was good my drone maintain well altitude loiter works fine also. So before this flight I’ve try to do autotune but I’ve got failled message failled to initialize failled to level drone I think… Just before to try it I’ve done level horizonclaibration with QGroudControl, I flex just after in AltHold and evrythink works well.
One strange thing in auto log analysis I got Compass = FAIL - Large change in mag_field (749.80%) Max mag field length (2024.80) > recommended (550.00) this is strange beceause I done a compass calibration with QGruondControl and I was in the green part after the calibration.

Here is 1 bin file the first is after level horizon and the second is the crash.
If I can have some help with my log files to understand what happened, for me it’s look like I suffered an ESC or motor issue :sleepy:
12 01-01-1980 01-00-00.bin (324 KB)

Thrust loss on Motor 3, Motor 4 dropped to compensate, Thrust Loss error message in the log, down it goes.

The Auto Analysis Tool is not up to date. Ignore it.

Hum yes I’ve saw motor loss in log analysis. Do you what could be the cause of motor loss? Hardware esc or motor issue?

No. It could be those or a prop failure, hard to say which from the log.

Yes this is hard to investigate the issue, because I really don’t know what happened. I don’t know if the issue is due to hardware or ardupilot tuning

I would doubt that. Post a log where it’s flying well.

Here is log for me when it’s flying well

For information my motor are F60 PRO IV FPV RACING KV1750 from T-MOTOR and my esc are also coming from T-MOTOR F35A-32bit 3-5S
For ESC I’ve just done an ESC semi auto calibration from ArduPilot, I’ve never change anything in ESC with BLHeliSuite32 maybe I missed something with my esc configuration…

Calibrations and tuning dont stop the motor from working mid flight. If the motor stopped producing thrust then It’s a fault with either:

power wires to the esc
signal wire to the esc
phase wires from the esc to the motor
esc failure
broken windings in the motor
loose magnets in the motor.

Unfortunately, it’s nearly impossible to narrow it down without video or esc telemetry.

Yes I know I don’t have esc telemtry and this is very annoying, I’ll search if my esc allow telemtry for futur fly :roll_eyes: but I think I can’t have this feature I don’t see any T port on my esc

I am fitting ESC telemetry compatible ESCs in all my new builds, multirotors, planes and rovers it takes the guessing out of what the motor was actually doing.

I have been where you are many many times and have had to resort to changing ESC, motor and propeller on customers machines just to be sure, since it was cheaper to just change the motor and ESC than risk having it crash again even if it was probably just a loose propeller…

1 Like

That’s usually what the “T” pad is for if this is what yuo have.

1 Like

Yes this is this esc I have but where is the T pad? This is the pad next to signal pad?

You can see the “T” in the photo…

Thanks for links @geofrancis I’ve tried this afternoon to configure pass through without success I can’t get valid esc configuration (I’ve created another post for this)

Oh yes sorry :sweat_smile: :relaxed: thanks @dkemxr I’ll implement telemetry for my next fly

You only need to make 2 parameter changes for passthru to work.
Set a Dshot protocol here:
MOT_PWM_TYPE (pick 600)
And set this to 1

Hum ok I’ll try it tomorrow. Because this afternoon I’ve set also SERVO9-14 with 33-38 value. So I’ll try to set only the 2 param you gave :+1:

Well, you have to assign the motors to the Aux outputs also of course. I didn’t think I had to mention that.

Yes, I’ve just tried to change params but without succes I can get my esc configuration.
I’ve set MOT_PWM_TYPE to 6 and SERVO_BLH_AUTO to 1 and I have SERVO1-6 to 33-38.
BLHeliSuite detect I have a multiple ESC but when I try to read the setup I got Found no valid esc configuration maybe these ESC doesn’t support by AP pass through.

I’ve also tried to use SERVO9-14 for Aux output without success. And for information when I set MOT_PWM_TYPE to 6 for DShot I can’t run anymore a motor test, I have to set this param to 0 if I want to be able to run a motor test