Copter flips on take off

So my copter flips on take off.

The motors are wired correctly and all spin the correct way.
The board is on backwards. I set yaw to 180 in the ahrs orientation under the advanced parameter tab to account for this.

When I hold the copter, add thrust, and tilt it in a direction, the copter thrusts in such a way that the error is made worse, not corrected.

I’ve had it flying before with different motors, the standard auto pilot orientation, and copter 4.2.

I’m sure I’m missing something simple here.
Any pointers?

So in Mission Planners Motor Test they run in the proper order and direction relative to the front of the craft?

Yep. The run correctly.

I’m poking about and found that pitch is inverted.
Any idea how to fix it?

Do it on your Transmitter. That’s the most common way. With OpenTx/EdgeTx just Invert chan 2 on the output tab.

Its inverted in mission planner too.

I think this is cause the autopilot to flip over on take off.

Will changing it on the transmitter fix this?

Probably. Every multirotor I have running Arducopter (many) have the Pitch channel inverted on the Transmitter.

That didn’t fix it.

In mission planner, if I tilt the copter nose up, the HUD shows the copter as nose down.

This is what it should look like with the front pitched up.

Post your parameter file.

Thats what pitching up looks like for me.

Here is my param file.
ChimkeeParm.param (20.2 KB)

I’m sure its something simple I am missing. I just can’t find out what it is.

If you flipped the FC around you have this still at default:

Set those Custom values back to default and make the change to the above in the Full Parameters list. Power cycle the board after making the change.


Welp. That was the problem. I missed the flavor text that said “This parameter is only used when AHRS_ORIENTATION is set to custom.” so it did not change the orientation when I changed the value.

All right. I went out and tested it and it worked perfectly. Thank you so much for the help.