Servers by jDrones

Copter 4 autotune problem

i’m stuck on autotune with my new build
i completed tuning process instruction and copter was sable enough to run autotune
but after autotune copter is completely unstable , i faced bad takeoff and wobble after applying roll and pitch

PIDs after autotune :

config :
CUAV Pixhawk 2.4.6 with copter 4.0.3 firmware
T-motor AirGear 450 with 1045 propellers
Emax BLHeli oneshot 125 20A
F450 frame
copter weight is 1600g

autotune log
bad takeoff and wobbling log
another wobbling log

@Leonardthall

What were your PID’s before and after autotune, for pitch and roll?

When that has happened to me, it’s because autotune put my PID’s too low. But my vehicles are tiny, and autotune didn’t really know how to handle them (seems better the last couple versions of ardu…)
But for yours, it’s a relatively standard size copter. Someone better at analyzing logs might be able to tell you why it’s not tuning well.
But anyway, my guess is that your PID’s are currently too low so the copter can’t control itself well.

If your autotune_aggr setting was at .05, try again at .1 .

When I run auto-tune, I always use a .05 first then after that completes I use .1 then do it again

For me it seems if I try a .1 first it takes a while to complete and I have battery draining issues

So i prefer a stepped procedure

ok
i updated my post
i started with default PIDs
and these are my PIDs after autotune

Those are very low.

If you haven’t already, go through the setup guide to be sure your filters and motor parameters are ok.
https://ardupilot.org/copter/docs/tuning-process-instructions.html

Then like I said, if you tuned at .05, do it again at .1.

When your motor output in hover looks like this you are not ready for autotune.

You have a clear problem with your motors. This causes an asymmetrical roll and pitch response that causes low values in the tune.

May be ESC calibration or settings, or it may be a damaged motor or incorrect kv. I hope it is something simple!!

Good luck working out the issue!

thanks @Leonardthall for your input
yes it seems that i was have ESC calibration problem with my last autotune
but i tried 2 Autotune before this and all was unsuccessful for example this , in this autotune motors are ok and copter was heavier
a note , i was using this FC with a smaller motors and it was autotuned with them and i was forgot to reset all parameters to default (only set default PIDs and anything in tuning process instruction till autotune) is this could make problem ?

UPDATE :
i did a full parameter reset and configured anything as new
this is the log file after full reset, is it ready to autotune @Leonardthall ?

You are still getting a strong asymmetric response but the reason is not obvious from the log:

It is hard to tell if you have fixed the asymmetric response problem but it looks like you have a noise problem:

You may be able to address some of this with the harmonic notch before autotune.

Hard to tell with the slow logging. I recommend:

1 Like

OK
this is the autotune log with recommended Log Bitmask
autotune log
hover after autotune

and this is the PIDs after autotune


roll and pitch are not same again , is it normal @Leonardthall ?
also please look at RCOUT in hover after autotune i think its abnormal

There is still a strong asymmetry in the roll response and I believe that this is why your roll tune is poor.

Pitch looks good:

You have a good amount of noise at ~110 Hz. Setting up the harmonic notch may help you:

On your post tune log I can see you have a lot of vibration in roll:

That is more than 0.5 degrees of roll vibration!

And you can see it on the rate output too:

You need to get this down before trying to AutoTune. Get the harmonic notch filter setup and make sure everything on your quad is solid.

Good luck!

1 Like

i did harmonic notch instruction, noise reduced from ~200 to ~10
before:

after:

but noise on RATE output did not changed

before :

after :

Actually it looks like it has got a lot better. The magnitude is 1/4 at least and it looks like you have a lot less high frequency components.

Hi
today i did autotune again, but no success

PIDs:

autotune log

@Leonardthall i’m using T-Motor AirGear 450 and propellers are soft, is soft propellers could make this problem ?

also i did a fly with these PID’s (calculated by myself from other flies) and Roll and DesRoll , Pitch and DesPitch was good same together


Log file (look at values before switching to autotune)

what is your idea ? is there something wrong with my copter or we faced an bug ?

what i checked in my copter :
propeller balance
ESC calibration
motors health
Psychically balance
X,Y,Z vibration
everything is solid in my build

There is nothing here to suggest a bug.

Your aircraft is getting inconsistent twitch tests.

You still have a lot of noise and this may mean you need to set the AGGR to 0.2 to compensate for the high noise levels. Are you able to film the tune too so I can look at the aircraft during flight?

Perfect

Is autotune_aggr = 0.2 safe ?
I don’t want to destroy this copter :sweat_smile:

Also some questions
The noise must be from motors or esc’s , is i’m right?
Is bigger frame could help?
My theory is make motors and esc’s far apart from FC

Yes, as always be careful on your first flight after autotune. This parameter does not change the tests just how far it will push the D and P terms. We want it to push higher and closer to your manual tune.

Most of the noise tends to come from the propeller passing over the arms and the high pressure air hitting the top of each arm. This shakes the frame. You then get noise from the frame moving, flexing and shaking. There is also noise from any unbalanced props or motors but this doesn’t tend to be huge on most systems unless you have damaged something.

Servers by jDrones