Servers by jDrones

Copter-4.0.0-rc2 available for beta testing!

This also allows to not to interrupt landing on RC failsafe, it was almost two years this feature was initially introduced, great it is in master!
BTW is there a possibility to handle failsafe events in scripting? So user could customize FS action logic basing on FS type, home dist, altitude, etc.

1 Like

Can’t find CubeOrange build, yet…

[LE] It appeared :slight_smile:

1 Like

SOLVED ok solved, i had downloaded the wrong firmware sorry

1 Like

ok solved, i had downloaded the wrong firmware sorry

1 Like

Complete details on the radio, gcs, and battery failsafe changes, as well as the new FS_OPTIONS parameter can be found in the blog post here: Failsafe updates for radio, GCS, and battery... plus new FS_OPTIONS parameter

1 Like

it’s conditions

  • cube orange
  • spektureworks board
  • here2 * 2 (using CAN)
  • arducopter4.0 rc2

I tried setting it up to use dual gps blend.

gps_type = 9 (uavcan)
gps_type2 = 9 (uavcan)
gps_auto_switch = 2 (blend)

The hdop value reports 655.3 and the arm does not work.

it’s seem to not report hdop value when using uavcan for gps

@sergbokh, we don’t have support for handling failsafes from Lua scripts but it’s on the to-do list. It’s unlikely to appear in the 4.0.0 release but perhaps as a point release in the future although I can’t really promise when exactly.

Lua scripts in master do allow changing the flight mode which will allow users to build custom failsafes. I.e. if something happens (like the vehicle going too far from home) the Lua script could trigger RTL or SmartRTL. I’m pretty sure the ability to changes modes will be included in a future point release (i.e. 4.0.1 or 4.0.2) because the coding is already done.

@rmackay9 any plans to backport FTP over mavlink support?

Anyone using FrSky passthrough telemetry?
I have sporadic issues since rc1: on vehicle power on @yaapu telemetry script on Taranis don’t get any data (but RC control is OK and the RSSI is also reported OK both by Taranis and by FC).
Restart of Taranis does not help. Only restarting FC could help.
I spent some time but didn’t found any stable steps to reproduce the issue. It is frequently but random.
I never had such issues on 3.6. Though its also possible a problem with my RC hardware.

“i) Yaw control fix for fast descent and after large attitude disturbances”: Note in my case the yaw was not related to altitude. tested today and yaw control on my y-6-b is working now but feels a little less responsive. I did get the props rotation a little during arming so i rebooted the battery and it was gone. Thanks everyone time to donate soon. PS never changed the motor that i was thinking the issue was from.

@sergbokh are you using a converter board with a max3232 IC?
When you say restarting the FC you mean power cycling or issuing a reboot via mavproxy for instance?

On the Orange Cube, the only way to have Passthru start is by booting with USB power, then plugging the lipo and unplugging the USB.
Haven’t tried 4.0 on anything else, yet.

@yaapu I’m using direct connection pixracer to r9slim+ SPort.
I do restart by power cycle but I will check if restart by MissionPlanner makes any difference.

Is this the same as the RPM filter in Betaflight, which depends on bidirectional Dshot in BlHeli_32, or something else? Is there a write up about the feature?

Sorry @Anthony_Short I should have put in a bit more color. It uses BLHeli telemetry, but only over UART currently. Bi-dir dshot will be supported when we support bi-dir dhot :slightly_smiling_face:

Hello,

I flew 4.0rc2 with an Y6 and Navio2 today.

There are still two problems so far:
Navio Led turn Green at early startup then turn Off and stay Off…
Oneshot125 is not working: PWM out stay in the 1000-2000 range even if Oneshot125 mode (2) is selected.

I tested Stabilize, AltHold, Loiter, Save waypoint, Auto mode (did the pattern twice in Auto), RTL.

Here is the .bin log
https://www.dropbox.com/s/wbs94n74w7ju4pb/2019-11-06%2013-49-39.bin?dl=0

Compiled version from the Ardupilot firmware link http://firmware.ardupilot.org/Copter/ doesn’t run on Emlid 2019-02-27 image. Some resources are missing. Compiled version on Navio2 Raspberry is fine.

1 Like

working fine here on pixracer 4.0.0rc2 + X4R.
Do you have an X series receiver to test with? I read about r9slims having issues with the s.port.

Ok, thanks for checking. Yes I have X-receiver, though it will be not very easy to connect to my copter.
I will flash 3.6 first to check if this is a hardware problem with my r9.

1 Like

AC 4.0 RC2 Working great with my Cube Orange. Thanks Randy.

1 Like

@mlebret, thanks for the report on the Navio2 issues. I’ve added them to our Copter-4.0 issues list so they won’t be forgotten.

Servers by jDrones