Servers by jDrones

Copter-3.6.0-rc7 released for beta testing!

beta-testing
beta-release

(rmackay9) #33

Gal,

Really sorry about the ch7/ch8 options disappearing from the MP. This should be fixed now though. If it’s still broken it might help to open the MP’s Flight Data screen, press Ctrl-F and then push the “Param gen” button from the left column, wait about 2 min and then restart the MP.


(brandon macdougall) #34

Solved: Had a bad led/usb unit. replaced it with another one and it works now.


(Pete) #35

I am having this issue also, I want to disable my compass due to the large amount of magnetic interference on a small frame.

I have found that with COMPASS_USE = 0 but MAG_ENABLE = 1, I can arm and fly in none position hold modes.

With COMPASS_USE = 0 and MAG_ENABLE = 0 I can’t arm in any mode, even with arm checks disabled.

I think its important with a large number of boards without compasses on now being supported that the full capability of Arducopter is available, all be it with more yaw drift than you would get with a compass fitted. I have been reading about abit I think it is just a check that needs to be turned off rather than a fundamental EKF issue, although i’m not too sure.

Thanks


(Gal Nitzan) #36

@rmackay9 Hi,
Regrettably, it is still the same, nothing changed.
I flashed to today’s fw build.

Both Ch7 Opt and Ch8 Opt are grayed out, in full parameters list both Options and Desc field for rc7_option and rc8_option are empty. The Value field was set manually by me.

I did clicked the Param Gen, but it looks like nothing happen.

Thanks,
Gal

ext tuning

ful params list


(S) #37

you could install the beta version of mission planner. it’s working for me.


(Gal Nitzan) #38

I am using the latest MP beta.

Anyways, I installed older version of MP 1.3.56 and flashed rc-7 again and now all is correct, voodoo.

Thanks,
Gal


(ppoirier) #39

Just received MATEK F405-STD
Flashed the Bootloader with dfu-util under Windows, please note I had to use Zadig to get the device driver being loaded correctly.
Updated to Mission Planner 1.3.58 to be able to flash the arducopter.apj file
I first loaded the latest beta http://firmware.ardupilot.org/Copter/beta/MatekF405/ from aug 9 but the IMU was really misaligned , reverted to aug 2 and could correctly proceed to initial setup

But the Compass is not working…LOL , I jut doubled checked the specs === There is NONE !!!

Looking at the definition , I can use an external on I2C, ok cool , next step …


(S) #40

Now that a page is made for this…
http://ardupilot.org/copter/docs/common-omnibusnanov6.html

Does anyone know if the fourth uart, RX4 on the ESC port, is active for ESC telemetry?


(Matt K) #42

Further to the discussion on the use of compass with F405 boards on small frames, I added a compass to see if I could get my race quad to switch to a gps enabled mode (like loiter). I am pleased to say that adding the compass has worked well. I have since been able to do a position hold autotune and have managed to get the quad flying well. In fact, flying with acro handling characteristics very similar to how it did on betaflight (which I am very pleased about!). I will say that I have done this on a dev build (9th Aug) as the beta wont allow me to arm (bad logging).

The only trouble is that I didn’t want to have to run a compass on my race quad. Given the really limited real estate, I cant fit a compass and gps unit nicely into my quad (it’s just glued on top at the moment and does’t look very good). Additionally after running a compass-motor tune I get a max interference of 170%. The compensation does seem to have worked well as I haven’t had any EKF or AHRS errors yet. So I agree with @iampete that it would be great if we resolved the issue of being able to use gps mode without compass. I think that it is simply an issue of the way the EKF failsafe checks for a compass that needs adapting (i am certainly not sure though). If anybody has any advice I would be happy to try fixing it.


(Gal Nitzan) #43

Hi,
Just wanted to report, had great flights this morning:

Frame: Iron Man F650 X
Motors: Tarot 4114 320kv
FC: Holybro Pixhawk 4 (FMU_v5)
FW: Copter-3.6.0-rc7
Batt: 6s 16000mah
RX: X8R
AUW: 3250g

Checked the following modes:
Stabilized, AltHold, PosHold, Loiter, RTL and AutoTune.
With out of the box PID defaults flights were really stable.

Only thing though and I’m not sure if its my error or not, when AutoTune was done (it took about 11 minutes) I flipped the RTL and the copter landed and disarmed. I went to my laptop and refreshed the params, however nothing has changed, parameters were not saved.

What am I missing ? did the disarming of the RTL failed to save the AutoTune parameters?

I’m not that good at reading logs but I think I went by the book. Any insight would be very welcome.
Auto tune log

Best Gal


(mlebret) #44

At the end of autotune, you have to land, still in autotune (completed) mode.

The wiki you will follow in order to achieve your quest,

Marc


(Roland Mayer) #45

Hello Randy,
now I have also ChibiOS on CUAV Pixhack V3.

  • CH12 Opt for relay working
  • internal compass one not detected
  • IMU fast sampling not possible (also on 3.5.5) on Cube IMU 1 and 3 are fast sampling
    can not trigger compass calibration with stick full throttle rudder right with Oneshot enable, esc on AUX - sorry - did another test and now compass calibration works
  • Poshold, RTH, Simple, Supersimple tested and working super as the new Loiter
  • MaxT around 3000
  • did some Autotune but get ATC_ANG_*** values at 18 for the Quad 700 with 700KV Motors (Oneshot125)
    about 20 flights with no issues - great work - thanks :+1:
    3.6.0-RC7_02_manuell-PID.param (14.4 KB)

(Dave) #46

I would also like to know if ESC telemetry is available on the F4 Nano V6. If so I’ll buy the more expensive 4 in 1 for the 130 quad build I’m working on.

Edit: Wait a minute. As there is no logging available on this board what use would ESC telemetry be? OK, I see the telemetry data is selectable in Mission Planner on the Tuning screen.


(Gal Nitzan) #47

Hi Marc,
So even though AutoTune was engaged, by turning RTL, I was out of AT?

Thanks,
Gal


(S) #48

You can still record its values through the telemetry link to MP. And I’m guessing it would be good for compass mot, on a small quad like these.

I’ve already ordered the board, so I’ll let you know how it works out.


(mlebret) #49

IMHO when RTL is engaged, AutoTune is disabled.

Marc


(Gal Nitzan) #50

Thank you Marc for your input, much appreciated
Gal


(Dave) #51

I ordered one also but the Hardware Definition file for this board makes no mention of a UART4. Maybe I’m missing something? It also notes pullup required on I2C but the connection diagram doesn’t indicate that.


(S) #52

I noticed that too, but I’m not a programmer and unsure where to go from here.

I was hoping someone would reach out to hwurzburg over on the chat to ask him about it… He was working on the board about a month ago.
I also saw a post by him about the pullups… He was asking to see if it was maybe possible to slow down the i2c bus, so they wouldn’t be necessary, but I don’t think he ever went down that path… Not sure…

(And sorry Dev guys, I swear I’m not a stalker! I’m just trying to keep up on the development of these new small boards)


(zhangpeng) #53

@rmackay9

I followed the steps of the wiki and smoothly brushed the Ardupilot ChibiOS 3.6rc7 version of Heli firmware into the FC of OmnnibusF4 Pro V3. In the MP, follow the familiar steps to debug an antique-class traditional aileron helicopter. The previous steps went smoothly. It includes its own interface definition, Bec power supply, servo connection, receiver connection, accelerometer calibration, transmitter calibration, etc., including custom pwm6 for esc control interface. The ground unlocking and esc output control tests, as well as the servo motion test, looked very smooth and should be able to test flight quickly.

Then, I connected a GPS module with an external compass on Uart6 and prepared to calibrate the external compass according to the previous multiple use. However, on the progress page of the compass calibration, I found that there is no calibration compass on any attempt. Progress bar. No matter whether it is a compass 1, 2 or 3, it does not.

Enter the parameter list, you can see that the ID of the automatically recognized Compass 1 is 466433, but why can’t it be calibrated?