Copter-3.5 Testing List

I have just connected an older 3DR radio to the Pixracer and have no problems with that one.

750mm quad , pixracer 3.5rc1

loiter: ok
parachute: ok (ground test)

compass auto learn does not modify live calib values

tried so far:
compass live calib with compasmot , flight log reported mag error by MP auto analys above 60%
compass autolearn did not change values , reported mag error by MP auto analysis above 60%
COMPASS_LEARN set to 0 1 2 do not produce any change in params (no sure if they are supposed to)

Is it possible that MP auto analysis tool is not working properly ? (MP

For testing purposes i did the following test
flown an auto mission with WP_YAW_BEHAVIOR set to 2, no ROI set, then flown the same mission with ROI set.
Copter orientation maintained according to ROI PERFECT!
Superimposing flight paths in google earth there are differences less than 1.5m between the two flight.

No reason to believe compass is not working as expected but the numbers.

Second issue i was not able to change the speed no matter how i set it. wp nav speed is set to 650cm/s. changed speed in MP to 700cm/s no effect, (both columns) , max speed it was able to achive 500cm/s



I think the difference between an X and an H is just the direction of the propellers. It’s not a change in shape of the frame. So some vehicle manufacturers (including EnRoute) make vehicle frames that physically look like the letter “H”. This doesn’t mean they’re “H” frames from an ardupilot point of view though. To ArduPilot, an “H” is the same as an “X” except the motors spin in the opposite direction.

I’ve just added “H” frame support for Hexa and Octa so this should go out with -rc2. There is a danger though that hexa/octa people who were confused about the difference between H and X will find their vehicles don’t fly on AC3.5.

@rmackay9 You should notify @meee1 of that, otherwise I think those options won’t be selectable in MP (in the setup screen).

I have started a new topic regarding the H frame as it’s going off topic:-

Hello, also tested 3.5 on Quad+ sucessfully.
Stab, Alt-Hold, Pos-hold, Loiter, Autotune - all fine - feels more smooth - less vibs - seems performing better Alt-hold
Trouble with Compass calib. after some parameter reset and firmware installations I realised that if the TX is on the AUAV-X2 hang - refuse working when I turn the copter more than 90°. This occurs also during mag-calib. The green bars start to move then stop before the copter is upside down. With no TX on I can move the copter in wild direction without the HUD stopping and the AUAV stop working. It happen wit USB or Bluetooth connection.
Also notice that just Imu0 has ID number in AUAV-X2 - in 3.4 both Imu initialised
I use Jeti RX with sbus
Ultra-esc with oneshot 125

Maybe someone can reproduce this behaviour
113.BIN (3.1 MB)

Did some more testing with RX ppm, RX separate power, conected with Android tower and apm-planner. Always the same. After rotating more than prox 60 degree HUD stopping no response from AUAV-X2.

another update of this mysterious behaviour from AUAV-x" and probably other boards.
in my logic it has to do with something RC an Servo. So I did tests with disabled mnt_stab - and that’s the reason for stopping board working.

In my case it’s only stab-roll responsible for that behavior. At the moment I have just tested at PC with USB connected but probably the same with batt-power. Did test with motors slow spinning an pulling arms of copter down and shaking with no abnormality. I don’t want to do a flip with my 2.7 kg fotocopter for testing if this could happen also during flight.

MNT_STAB_ROLL enable cause board refuse working when tilting

RC11 - Gimbal tilt - SERVO5_FUNCTION,7
RC12 - Gimbal roll - SERVO7_FUNCTION,8

in the graph servo 7 goes to zero???
just after that board (AUAV-X2) stopping
127.BIN (430.3 KB)

@ardisd (David),
Thanks for the testing! Stopping at the fence in Loiter mode is normal behaviour (even in AC3.4 I think). In most other modes it will trigger the RTL but Loiter stops.

@Cipta (aka Roland),
Thanks for testing and reporting back.
My guess is that this is a power issue. The flight controller may “brownout” if the servos are being fed power from the flight controller. It’s best to use a BEC to power the servos.
Can you try enabling the ardupilot mount but physically disconnect the servos and then repeat the test? If it still fails with the servos connected then it’s possible we have a software bug. If it works fine with the servos disconnected then it’s likely a power issue.

Hello, thanks for reply.
Because safety-switch no servos moving even if there is a RC-out signal and also servos have separate power supply. Servo min max settings seems to have no effect. Mnt_Stab_roll brings the signal to zero. I have teste several times - just USB-connection with TX on the board stops. Now I disabled Mnt_Stab an no problem at all when calibrating compass or turn it upside down. Yesterday I tested circle modus an loiter and poshold - everything fine - good work.
He probably has the same symtoms


1 Like

i was using the servo out to drive a brushless gimbal so there was absolutly no extra load from servos.

what was strange was it ony locked up of i tried to arm too soon, if i put it in loiter and tried to arm it was usually ok thats why i initialy thought it was a ekf issue to begin with.

HOW CAN I SETUP frame for y6b ??? value 10 write me UNKNOWN !

1 Like

H frame
Motor testing is all ‘greyed’ out, not sure if this a firmware or a Mission Planner not recognising the frame type.


@ACPUK Mission Planner for sure. This is with the new Octa H option right? Can you open an issue in MP GitHub?

PrecLand tested successfully on AC3.5. (Frame : Quad, Pixhawk 2.1 and Pixhawk 1 clone 2.4, EK2, SF11 in Serial mode, I2C not tested yet)

Stablize, ALTH, Loiter, Land also tested with no issues.
I experienced some drifts in Loiter mode after a “roll” Left / right commands. Copter would take 1-3m to stop before keeping position. Maybe not related to 3.5, GPS signal was maybe not perfect.

1 Like

Pixracer clone on Y6B. LEDs working. Had to disable compass3 - no way to caibrate it.
Flies as good as with 3.4 in Stabilize, Alt hold, Pos Hold, Loiter, Land.
Battery FS (Land) works.
Yaw control is difficult to tune - with all props same size (14") it´s nearly impossible.
Now using 13" Top / 14" bottom and yaw works much better.
Connected a 600 mW Radio to Telem2 caused strong jitter in vcc and made Baro signal unusable. Funny: Connecting to Tower while flying in Alt Hold made the copter dropping 10m.
Now using a 100 mW Module - better, but vcc still not perfect.
Will try mission flying when wind calms down.


hey man, how did you enable pixracer LEDs?

Artemen, I just answered you in the other thread but in any case, there’s nothing special you need to do to enable the Pixracer LEDs. Just load the board with AC3.5-rc1 which is available through the ground stations (MP and QGC). With MP there’s a “Beta firmwares” link on the “Install Firmware” page. I’ve just double checked and the LEDs work.

Thanks for such a fast reply…
So, though MP has AC3.5 stable, should I be loading rc1 instead?

My bad, its ac3.4.5 whivh is available as stable… Will try ac3.5rc1…
Sorry… to little sleep. :slight_smile: