Servers by jDrones

Copter 3.4-rc5 Almost flip, landing detection failure

Was running rc3 without big issues, now tried the rc5 and things went very bad.

  1. When taking off in AltHold, when you raise the throttle usually motors does a “pulse”. This always happened and I’m almost familiar with them. But now the pulse is so strong the quad almost flip (some props hit the ground). Seems it tries to level and give throttle to the lower motors. Did full throttle and it leveled fine.

Note: My quad is overpowered. When battery is full it hovers with 25%. This “pre takeoff pulse” gave 45% throttle instantly to 2 motors.

  1. The quad flew nicely, landed twice, on the third land things went bad again. The landing detector didn’t work. Motors keep running at SPIN_MIN and then suddenly it tried to “level” it self, again giving 50% of throttle to 2 motors and almost flipping. Full throttle, took off and tried again, but this time as soon it landed I hold the quad down. It tried to level itself again and after a few seconds disarmed (later I saw it the logs it only disarmed due to the crash detector).

Here is the log file

Guys, any chance to someone have a look at my log? I understand some of these issues might be related to the overpower, but the same setup worked fine on 3.3, and preventing the quad from disarming is a safety issue.

Hello,

Have you tried to calibrate your ESCs to test if the “pulses” are gone?

Before 3.4RC2 (including v3.3.3):

c) THR_MIN becomes MOT_SPIN_MIN
d) THR_MID becomes MOT_THST_HOVER

There is (was) a document explaining how to obtain THR_MID (i.e. hover for a while @Stabilize and the average of the hover was your THR_MID power setting)

Now that is gone, now you have MOT_THST_HOVER default is 0.5. Best value for this setting is obtained automatically (MOT_HOVER_LEARN,2). That should keep a smooth transition between Stabilize mod and Alt Hold.

Regarding your motors still spinning at idle, MOT_SPIN_ARM, set to 0

Haven’t seen your log yet (though I’m not expert).

I’m too having issues with RC5, so I guess I’m going back to 3.3.3. :slight_smile:

@candanga,

Thanks for trying to help, but everything you mentioned was already checked and rechecked. Transition from AltHold to Stabilize is smooth, ESCs calibrated. Overall the quad flies pretty well, the onlyy problems are on takeoff and landing.

Then, do the same as I did, roll back to 3.3.3 :slight_smile:

This is supposed the place to give feedback to developers, rolling back would not help.

An update to the issue. Replaced the motores to lower KV, the pulse during the takeoff on AltHold is still present but doesn’t cause any hurt as it isn’t engough to move the craft.

The disarm issue is still present, I can however disarm in stabilize (even when landed in Loiter/AltHold, if the quad doesn’t detect landing I need to switch to Stabilize and it will “land”.

Hi, did you find a solution to the landing detection issue? My quad took off and flipped today right after landing. Never had this happen before with 3.3. I wasn’t quick enough to switch back to althold and disarm. I’ve posted the log in a separate topic.

I just posted an identical problem on the copter 3.1 board 30 seconds ago.

It sounds like you would benefit by adjusting your throttle mid so you have more fine tuned controls for lift.

My thinking is the same as you - switch to stabilize with 0 throttle should be no problem.

I wonder if the desperate last minute disarm we are attempting is actually making it worse by putting in full yaw when the thing doesnt know it is landed.

Curious for more info on this!

I had a case with 3.3.3 when the copter landed on uneven ground, took off then landed again, but the attitude was perfectly under control, it never ever tilted until complete landing. Today’s case was on flat asphalt, and I see in the log some “Desired” roll/pitch and not yaw. It wanted to tilt and in fact tilted before the panic disarm move. There is a change in yaw, but it is ahead of DesYaw and not caused by it. Also I didn’t touch the pitch/roll stick, which is confirmed in RCIN.C1 and RCIN.C2. Here is my thread with log.

Servers by jDrones