Controlling mount modes tarot 2d , pixhawk plane


New here, i have read many threads about gimbal control problems. I have followed the wiki step by step and i can control the tilt with “point camera here” option when right clicking on the map in mp.

However , i canot get control over the gimball with my rc ( ch7). it seams like I canot control the mnt_modes. This parameter is gone and replaced by mnt_default_mode. I have set this param to 3 (rc). But The gimbal is always tracking the point on the map.

I have tried changing mnt modes from the action tab in flight data, but that did work as well.

If I set ch9 to passthrough I can control the tilt directly from the radio but then i lose the gps point option.

So , how do l change / check the mnt_modes from rc to gps and back ?

Thanks for the help


Made some progress today,

I have found thet CH7(tilt input) params where a mess this is how I changed them to support 1000-1520 pwm set in the gimbal setting page:

RC7_max = 1520
RC7_Min = 1000
MNT_Joystick_spd = 100

I have set the knob on the transmitter so that it outputs 1000 to 1520 with 1244 set at the neutral to 1244 .

now , when I turn the knob from the center to either sides the gimabl rotates and stops when the knob is centered. this is the way it works although the gimbal is set to position mode and not rate.

the only problm I have now is that after I do a point camera here command from the Flight Data map. the camera points and I can Never regain RC control over it .

I have tried Set Mount from the action tab - and it does nothing
I have tried changing flight modes - no change

the only thing that help me regain control was to reset the power to the pixhawk.

looking for Ideas on the subject


I was just stuck with the same problem…
and I finaly found the way to make it work !! :smiley:
you need to asign chanel 6 or 7 or 8 to “set mount” and do a quick flick of a switch to reset the gimbal :smile:
I will do a video soon on my chanel : (and yes I will do it in english)


I Did not find" set mount " in the chanel rc fnunction, was it mount open( value 9) ?

Does it have to be chan 6-8 ?

I understand it returns to the default mount mode after the switch flic ?


Sorry it’s “retract mount” en yea it’ only on channel 7 or 8

Did you find the option ?
Would you like me to make a video in english ? (or in french)


I found only mount open did not havr time to test , video in English will be great



Ok I will try to be understandable :smiley: (cause I’m still studying englis at school and i’m french :laughing:)
Video probably out tomorow or Friday.

hi there it is :wink:

hope my english is good enough :slight_smile:

Very nice, thank you.

I am using plane not quad so the interface is different .

I will try to assign a mount retract channel

What gimbal are you using ?

Take care.

I’m using a Storm32 board with a chiness gimbal…
Find at 70$ on GoodLuckBuy.
And this thing is a blast !! :smiley: