Constant beeping on start-up


I’m new to this so please be forgive my ignorance. I had my maiden flight this morning without a gimbal and having followed the instructions. All went pretty well but ended with a minor crash from 1 ft high. I turned it off and then came back to it this afternoon. However, since then all it has done is beeped at me. I have tried to look at Droid Planner to see what is wrong but can’t see any easy way to find out. The beeps are :
Three short beeps, followed by Three long beeps.

Does anyone have any ideas as to what i have done wrong?


Please post tlogs and/or data flash logs of your flight to help troubleshoot your issue.

IIRC I read someone had similar and it turned out to be a disconnected cable on the receiver or other box in the Iris. If a cable wasn’t fully seated from the mfg a bumpy landing might shake it loose. As TC said, post the logs, but also take a look inside, might be a quick fix.

BTW, I am jealous of your first flight. Winter won’t let go around here and this is another freezing snow/ice storm weekend. I have to be content flying my Blade Nano in the house.

Hi there,

I looked inside and all seems ok. The ATP light was flashing blue, that’s all.

As for the Logs, I have attached them - I hope these are correct. How is the easiest way to understand them?

Many thanks again,

Based on the sounds you just gave, the SD card is missing or fell out.

Check this page and look for notification tones.


Great - thank you. That seems to have fixed it!