Connecting Pixfalcon outputs to servos and ESC

Hi! I am trying to connect the pixfalcon to the servos and ESC. It is provided with the standard supply of pixfalcon a cable (output cable at the “manual”) but I see only one connector for servos. That it means I have to take the power from the power module for each servo? And the motor, is it connected directly to the 3 pins connector? Sorry for this basic question, I am a beginner.

I have an early Pixfalcon and it was really designed for a small quad multicopter if you look at all of the available accessories. I think that you would be better off with a clone Pixhawk in my opinion.
Like the Pixhawk, the Pixfalcon servo output power bus must be powered externally from either a standalone BEC or the BEC built into the ESC.
Where did you buy your Pixfalcon from, HK?

Thank you Thomas! Afirmative, hobbyking. I miss some extra manuals.
Is there any problem if I use the powermodule? It has some extra outputs. My ESC is covered. There is cable from ESC to the pixfalcon which I could connect to the servos, but I would need a proper connection.
I am mounting pixfalcon in a light plane. I use pixhawk too but I am saving some grams.


I’m revisiting this because I’m now having trouble where I wasn’t before, and this thread is the nearest match. let me know if it should be moved to Copter or Hardware categories.

Pixfalcon on X quadcopter (sorry, not a plane)
Arducopter 3.5.3
Dropper servo attached to main output 5, RC input channel 6
I can set SERVO5_FUNCTION to 0 for use in missions (Do set servo commands) or for Channel 6 RC pass-through to manually operate it - and all works as expected.

The dropper servo hasn’t been used for a while. Arducopter is updated over time…
We wanted to change it’s function to camera tilt.

Arducopter 3.5.4
Servo attached to main output 5 or 6 (as before)
Tried RC pass-though, gimbal tilt (stabilise), servo functions of all sorts…
Tried different servos, 5volts still available at servo, continuity on PWM signal wire all the way between servo and Pixfalcon…
Servo cannot be made to respond in any way shape or form.
Pixfalcon DOESNT have AUX outputs, but surely we can still use main outputs that are not dedicated to motors (or other controls for planes)?

Any pointers on what parameters to try are appreciated. I may just be missing something.

Thinking about it more, I’ll do these and report back:

  • set logging disarmed=enable and check logs for RC6 input and servo outputs
  • recheck wiring, power, ground and so on

Do you know that the motor outputs are not enabled until the safety switch is enabled?

yeah tried arming the copter, motors running, still no servo action.
The old dropper servo set up used to just work any time when we had it working from RC6 channel.

I figured it out, I’ve got a connector between the pixfalcon servo wiring and the quadcopter wiring (esc’s and 2 servo connectors) and the two servo pins we’re pushing back out of their housing and not making proper contact Now properly fixed.

I found it by checking the logs and seeing that the pixfalcon was outputting signal on main output 6 in conjunction with RC 6 input, so I knew where to go looking then.

With servo 6 function set to RC pass-throught the servo now operates with RC channel 6 even while disarmed.

The next problem is now getting the tilt stabilisation to work. I set the servo 6 function to mount_tilt and select stabilise, disable RC 6 input (and tried it enabled too) but there’s NO automatic servo movement generated by the pixfalcon whatsoever.

So am I missing gimbal/mount settings? I only want to stabilise tilt.