Connect to Pi3 USB wifi adapter instead of built in wifi

Hello everyone, would someone please help me to figure out how to setup and use my RPI3 external wifi dongle MT7601U (wlan1) and not the default (wlan0) onboard antenna? I am using the APSync image from ardupilot.
I already setup my companion computer, and when I connect my USB wifi adapter and I run the command " sudo iwlist wlan1 scan | grep ESSID " i can see the surrounded wifi access points near my RPI3
Thank you!!

Well… that seems to be working well enough so far.

What did you want to actually do with the device?

You might like to google for “nmcli tutorial” - that’s the usual way to
configure this sort of thing from the command-line.


Thank you Peterbarker for your answer,
I am trying to disable onboard wifi (wlan0) and use dongle (wlan1) to increase the connection range.

Actually when i connect my USB dongle MT7601U to my RPI3 model B i want this to be used as interface and not the onboard small interface. At this point now i can see both wlan0 and wlan1 on,

when i disable the wlan0 by adding " blacklist brcmfmac blacklist brcmutil" in /etc/modprobe.d and sudo reboot my companion computer uses the external wifi dongle by setting it on wlan0 interface , but the problem is the ardupilot wifi access points disappears also.


I’m looking to do the same thing, I have a usb adapter as wlan1. I’d like to have apsync access point on wlan1 and use wlan0 to connect to my local router. Any advice on how to configure this?

You’ll need to edit /etc/dnsmasq.d/WiFiAP.conf and change the line interface=wlan0 to interface=wlan1

1 Like

Thank you, that worked for me

I am trying the same thing but WiFiAP.conf doesnot exist.

Then you are likely not using the correct image. See apsync-Kakute/ at master · stephendade/apsync-Kakute · GitHub for how to create the WiFiAP.conf

My exact problem is that how to connect to another networks through apsync ? How can I disable apsync wifi-access point and connect it to other wifi networks ?

You can disable the Wifi AP via sudo nmcli connection down WiFiAP

To connect to a different Wifi network, there are plenty of tutorials on the Internet for using nmcli to manage network connections.

My apsync image doesnot have nmcli downloaded and its not getting connected to internet. Is their any latest apsync image which have nmcli prebuild. or how to connect to internet to apsync image.

Thanks for your help!!

All recent APSync images should have nmcli installed. Where did you download your image from?

I used the below link