Confirmation that this crash was due to a failed motor

Hey I’ve got some logs from yesterday of a pretty nasty crash that we saw with our Foxtech GAIA 160S hexacopter. We have it equipped with a Pixhawk 2.1, HERE 2 Gps, etc.

The drone was experiencing some high-ish winds (gusting to maybe 15mph at most) while we were flying it. It made the drone fly turbulently enough to cause us to bring it back down below the tree line where the winds were lower. We then flew it out from us maybe 350 feet. At this point we saw what appeared to be a motor failure and a copter trying its hardest to stay in the air. It was yawing wildly and I saw no hope of getting it back in Loiter mode so I switched to RTL at which pointed it fell out of the sky.

We were able to recover the drone but surely suffered close to $10K in damages. Looking at the logs I see RCOUT C7 peak and C8 drop to the bottom. In my mind this would indicate that C7 died but pixhawk was begging it to keep spinning and C8 shut off in response. C8 is motor 2 which should be a the 9o’clock position on the drone and C7 is the motor at the 3o’clock position on the drone. (I would need correction here if I am wrong about that).

I would just like a second look at the logs for someone to confirm that is indeed the case and would also welcome any speculation as to why this happened. Of course we want to repair this drone and keep flying but would like some assurance we are stopping it from happening again.

https://drive.google.com/file/d/1Drt_TQKc05NIUdWoqIP78XeUlVyI_y-p/view?usp=sharing

https://drive.google.com/file/d/19T3Hz1pd74lGElAZkPe1XS_OaP1edsHG/view?usp=sharing

Thanks,
Asher

I would agree with that. Thrust loss on Motor 1. ESC, Motor or prop.

Thanks for the response.

I can say for sure that the motor still spins up fine here at home. The prop was undamaged and the motor seems to spin smoothly. Any ideas what could have failed in the air? Could it be an ESC desync?

Perhaps so. It’s this combination on 12S power?

GAIA

Yes it was on 12S. We’ve always flown it on 12S

So I recovered the motor that quit spinning and using the same batts, props, ESC and motor, I strapped it down inside and used my receiver to spin it up and it looked and sounded great.

Further, I then started varying the throttle pretty wildly to see if I could see any sign of a desync. The motor behaved perfectly normal and motor and ESC hardly heated up at all after the test.

If the motor desynced in the air, shouldn’t I be able to recreate it with some consistency on the ground? The success of the above tests casts doubt on the desync theory. I suppose the other theory is some kind of mechanical failure/electrical disconnect of the arm while in flight. Once we recovered the drone on the ground, essentially all the arms were ripped off but perhaps Motor 1 began to slip off while in the air?

If someone has similar experiences, it would be great to know.

Hi! I had desync problems with T-Motor ESC in the past, for me were the T-80A, so I recommend you to change them, I personally trust in Hobbywing.

A very weird thing that I have observed in the log is that the drone fell out due to a “crash: Disarming” error while it was flying… That stopped all the motors. Here you can see it:

I don’t know exactly why it was disarmed the drone in that case, one thing is that Pitch and desired Pitch were different for more than 30 degrees for 2 seconds. But although I see a difference when the motor failed, I don’t see enough to trigger that…

I hope that can help you a bit more.

David,

Thanks for taking the time to reply. And yeah that motor shutoff event happened at the exact moment I changed my flightmode to RTL. I assume that is what triggered it, but I don’t know why.

And thats good info the the T-Motor ESCs. The rest of what we’ve seen so far would point to an arm failure, but I suppose the desync is still on the table.

Thanks,
Asher

The more I look through these forums the more I seen a common trend for Hexacopter users (could also happen with Octo but less likely).

In the event of a Motor failure the aircraft will begin to spin. This is expected. The issue though appears that if the aircraft switches into RTL while experiencing loss of yaw control the aircraft will disarm/crash. I don’t have links to other post at this moment but I have seen many similar posts now. I am assuming this same issue would happen on an Octo if loss of Yaw was experienced.
I would guess the same issue occurs with the aircraft is in an auto mission.
@Leonardthall Any ideas here?

Doubt the Alpha ESC’s are de-syncing. Like you mentioned probably a cable/connector issue. Are the ESC’s in the body of the aircraft or at the the end of the arms?

Chris,

Thanks for looking through the logs. And yeah the ESCs are mounted directly under the motors. So PWM and batt power are going through the arms.

T-Motor ESCs desynch a lot. Flames seem more prone to it then Alphas. My personal feeling is that Alphas actually have a better recovery algorithm.
In the realm of 12S and big props, my only success story is with 170 kV and 24 inch props. All attempts at lower kV and bigger props were only doing OK flying very slow in standstill weather. Any wind gust or demanding flying ended up in oscillations, hard landings or downright crash, due to motors de-syincing.

It’s been a year since I last tried a test, though, but my hopes were that APD ESCs would perform better. Sadly, back then, they didn’t like the DShot300 the Pixhawk family outputs, as that’s the minimum protocol they accept as input.

I have Alpha ESC on many aircraft including:
Alpha 60 / MN605 / 170kv 22" - 1600mm Octocopter
Alpha 60 / U8 100kv / 28" props - 1400mm X8
Alpha 80 / MN705 125kv / 27" props - 1400mm X8

In several thousand flights I have never seen any signs of de-syncing. The U8 and MN705 aircraft are using DJI A3 and they fly with incredible stability, 40km/h winds are no problem and they have no problem doing 100km/s in still air. That being said I haven’t tried them with Ardupilot.
The MN605 22" Octocopter is using ArduPilot and it flies amazingly as well.

Asher: I know its a pain but I would highly suggest putting Electrolytic Capacitors (1000uF / 63V) in the power lines close to the speed controllers. I had major problems with ESC failures on my “Alpha 60 / MN605 / 170kv 22” - 1600mm Octocopter" because of long power leads was causing excessive ripple voltage that was frying the capacitors on the Alpha 60 ESC’s.

The large angle errors caused a crash check. We have added an additional check to prevent this particular failure from happening.

You did not say what ESC is being used here, Flame or Alpha.
Flames suck, Alphas seem to do alright.

The ESCs are flame 60A. I actually didn’t know they weren’t considered to be as good.

I am used to thinking about desyncs in relation to small betaflight race quads where the quads just crash if there’s a desync. Do ESCs this large on large drone platforms have ways to resync and recover?

Hi,
i am using APD 80F3 with DShot300 on Pixhack without any problems. Telemetry from ESC is very useful, especially in these cases.

Yeah I’ve never actually heard of APD ESCs. Their website looks pretty good though. They give much more detail than a t motor page would.

What kind of craft are you powering with them?

I use them on a 650mm quadcopter with a T-motor MN5008 and 16" props.

The problem with the Flames isn’t desync, it is over current. If they draw too much current they shut down and need a power cycle to start again. This really annoys me because it is just lazy design and programming. This is the definition of “not a multirotor esc”. This is one of the reasons I do not use T-Motor stuff at all anymore, that and their mid sized motors fall apart (regularly check them, if you see any play disassemble the motor and there is a good chance you will find their design flaw).

As I say though, Alphas seem to work well.

2 Likes


After RCOU.C7/C8 go to extreme values, it seems to turn five times once every 10 seconds (slowly), but with ATT.Yaw following ATT.DesYaw, with RCIN.C4 not altered in Loiter mode. If they are opposite motors they should rotate in the same direction, so if one stops may be that somewhere it is decided to turn fully on the opposite motor.

Hi - I’m also trying to troubleshoot my Tmotor setup and curious if anyone has some thoughts on what’s going on.

It’s the Alpha 60A HV + MN501Skv240 + 15x5 props (to my knowledge this appropriately spec’d), with hover throttle QTUN.ThrH ~.45-.50.

Routinely, during a steady hover, it’ll become unstable momentarily, or descend to the ground. It always corresponds to a motor signal saturating and its diagonal pair pulling back. Right when this happens, that corner will dip (des.roll and roll, likewise pitch diverge). I think(?) I’ve isolated it to an ESC/motor problem.

Here’s a plot from the ESC telem data (RPM: red, Throttle Output: purple)


This seems to ‘make sense’, with RPM ceasing to track the input. (but I want to figure out why :cry:)

I want to reserve blaming the Tmotor stuff as a last resort in my troubleshooting but I have seen a lot of comments pointing to them so that has me curious for sure.
Does anyone have some insights here? Thanks