Compasses Inconsistent in Octocopter (Solved)

I am lost. I need a help with constant message in Mission Planner “Compasses Inconsistent”. Just after take off I get such message. Compass is calibrated and mounted on quite high stand (15cm above everything). I have internal compass in Cube Orange which is disabled (in Mandatory Hardware/Compass/Compass #2 is disabled only Compass #1 has marked “Use this compass” and “externally mounted”) and RM 3100 Compass integrated in Drotek Sirius F9P GPS. This RM 3100 was calibrated without problems several times. Two days ago everything was ok I just made some changes in wiring and added Lidar and HereFlow to my copter and changed some cables and position of escs.

As I understand this message shows that there is difference in measurements of magnet filed between my two compasses but why it still exists when I disabled internal compass ? What I am doing wrong ? On different copters I solved such problems by disabling internal compass.

My octocopter is flat octo, 6s, 16" propellers, Cube Orange, Arducopter 4.03, Lidar Lightware Sf30d, HereFlow, RFD868.

Copter Flying ok in Position hold and Loiter.

In the log I get message “EKF IMU2 ground mag anomaly, yaw re-aligned”

AFAIK there are some bugfixes for the RM3100 in master that have not been ported to the stable release yet.

I found the problem and fixed it. I was trying to fly on my internal compass and disabled external RM 3100. That because in HW Info in Mission Planner the first compass is I2C RM 3100 and second is compass integrated in Cube Orange. Also in Complete Parameters list the first is RM 3100. Also in compasses in MP first compass was external second not. So in my wrong setup I set in Mission Planner that first compass was primary and that was integrated compass.

To fix it I had to change the second compass as external and make it as primary compass and disable first comapss which is to close to ESCs and power cables.

The numbers and names of compasses are confusing why RM 3100 on every list is first but it’s Compass 2 ?

@amilcarlucas please give some more info about this bugs. Anything serious why I shouldn’t use this compass in work with copter ?

Take a look at the RM3100 pull requests