Compass Setup help

Hi, I was wondering could somebody please help me to set up a compass. I have an apm 2.6 with a neo n8m gps/ compass. I didn’t know the orientation of the compass so I read online to turn the rover on its right side and rotate until the red line was facing north and I would find the forward pointing face of my compass. I did this then re postitioned my my compass as if it was correct then mine was facing inthe wrong direction. My direction was still a little off so I started to try different selectrions in the drop down menu of the compass box. Roll180yaw45 it seemed to point in the same direction as my rover is pointing. I dont kno what any of these are to be honest and would love some explaination. Also what are the red orange and black headings on my screen? what way do I want them to be pointing.

Also everything seems to be inverted. when i roll to the left the screen on missionplaner where fpv would be rolls right. If I hit forward on my throttle it goes in reverese and I also think the same is for left and right. I have tried accelerometer, Compass and radio calibrations.

After testing in the field im still having problems. I can’t seem to get the external compass to its correct orientation so I unpluged it. The onboard compss is working perfectly. Orentation is spot on but I still cant follow an auto mission, When i set auto it just drives arond in a circle at way point 1 then stops. I have tried to just set one waypoint at a distance in a stright line but It will not drive stright, It alwas tries to turn right.

As a side note the roll is still inverted and I think my controlls are too could this be a problem.

Thanks, Ive tried most things from that tutorial. I think ive actually managed to get a correct compass calibraton and orientation but i still cant run a auto mission for some reason.

When I switch to auto its like its just wants to circle around the first waypoint. Im selectin one point in a stright line from home. I set default altitude at 1. When I switch to auto do I have to select mission start? As soon as I select auto it just drives in a fast circle to the right. Sometimes reverses a little then drives forward again?

It has me stumped. By any chance is it possible to test my hardware and motors in simulation? I can run an auto sim and my rover icon will follow the directions but is there any way I can get my wheels to react to whats happening in the simulation?